summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-11 19:48:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-02-11 19:48:25 +0000
commitc63fde5c770b16b0203f9d48d08b7b4755e5dbe0 (patch)
tree3c8d26e2e6c256e7b66ddbdc62d1dd4c9f908b11 /c/src/lib/libbsp/i386/pc386/configure.ac
parent2009-02-11 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-c63fde5c770b16b0203f9d48d08b7b4755e5dbe0.tar.bz2
2009-02-11 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, start/start16.S: Remove duplicate configure option and add support for the configure time variable BSP_VIDEO_80x50.
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/configure.ac')
-rw-r--r--c/src/lib/libbsp/i386/pc386/configure.ac22
1 files changed, 10 insertions, 12 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/configure.ac b/c/src/lib/libbsp/i386/pc386/configure.ac
index 9988c1a4a0..f479d5a532 100644
--- a/c/src/lib/libbsp/i386/pc386/configure.ac
+++ b/c/src/lib/libbsp/i386/pc386/configure.ac
@@ -40,11 +40,18 @@ RTEMS_BSPOPTS_HELP([IDE_USE_SECONDARY_INTERFACE],
- and you have at least one disk attached to this interface
- and you do want to access disks attached to this interface])
+RTEMS_BSPOPTS_SET([BSP_VIDEO_80x50],[*],[0])
+RTEMS_BSPOPTS_HELP([BSP_VIDEO_80x50],
+[If defined, set the VGA display to 80x50.])
+
RTEMS_BSPOPTS_SET([BSP_PRESS_KEY_FOR_RESET],[*],[1])
RTEMS_BSPOPTS_HELP([BSP_PRESS_KEY_FOR_RESET],
-[Determines, whether this BSP will wait for a key to be pressed
- before rebooting the PC. This is useful for unattended PC deployments
-])
+[If defined, print a message and wait until pressed before resetting
+ board when application exits.])
+
+RTEMS_BSPOPTS_SET([BSP_RESET_BOARD_AT_EXIT],[*],[1])
+RTEMS_BSPOPTS_HELP([BSP_RESET_BOARD_AT_EXIT],
+[If defined, reset the board when the application exits.])
RTEMS_BSPOPTS_SET([CLOCK_DRIVER_USE_TSC],[*],[0])
RTEMS_BSPOPTS_HELP([CLOCK_DRIVER_USE_TSC],
@@ -93,15 +100,6 @@ RTEMS_CONFIG_BUILD_SUBDIRS(tools)
AC_SUBST(RTEMS_BSP)
-RTEMS_BSPOPTS_SET([BSP_PRESS_KEY_FOR_RESET],[*],[1])
-RTEMS_BSPOPTS_HELP([BSP_PRESS_KEY_FOR_RESET],
-[If defined, print a message and wait until pressed before resetting
- board when application exits.])
-
-RTEMS_BSPOPTS_SET([BSP_RESET_BOARD_AT_EXIT],[*],[1])
-RTEMS_BSPOPTS_HELP([BSP_RESET_BOARD_AT_EXIT],
-[If defined, reset the board when the application exits.])
-
BSP_BOOTCARD_OPTIONS
# Explicitly list all Makefiles here