summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2012-09-28 16:37:58 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2012-09-28 16:38:06 -0500
commit63241f80441658f289691d6e75a482360d7c251b (patch)
treeda4ea2fb585626300870cf628249afb27894bce8 /c/src/lib/libbsp/i386/pc386/configure.ac
parentFB driver for Cirrus GD5446 graphic hardware. (diff)
downloadrtems-63241f80441658f289691d6e75a482360d7c251b.tar.bz2
pc386: Add Cirrus FB Driver to Makefile and configure.ac
The user has to explicitly enable this driver, choosing it over the existing (and lame) CGA frame buffer driver using USE_CIRRUS_GD5446=1 on the configure command line.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i386/pc386/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/configure.ac b/c/src/lib/libbsp/i386/pc386/configure.ac
index 55dada8dd6..1125c7c8e0 100644
--- a/c/src/lib/libbsp/i386/pc386/configure.ac
+++ b/c/src/lib/libbsp/i386/pc386/configure.ac
@@ -74,6 +74,14 @@ RTEMS_BSPOPTS_HELP([CLOCK_DRIVER_USE_8254],
- you do not mind adding roughly 5 microseconds to each context switch.
])
+RTEMS_BSPOPTS_SET([USE_CIRRUS_GD5446],[*],[0])
+RTEMS_BSPOPTS_HELP([USE_CIRRUS_GD5446],
+[If defined, enable use of the Cirrus GD5446 controller rather than the very basic
+ VGA driver for frame buffer support.
+
+ NOTE: This has only been tested on Qemu.])
+AM_CONDITIONAL(USE_CIRRUS_GD5446,test "$USE_CIRRUS_GD5446" = "1")
+
if test X${CLOCK_DRIVER_USE_TSC} = X1 -a X${CLOCK_DRIVER_USE_8254} = X1 ; then
AC_MSG_ERROR([pc386 both TSC and 8254 specified for clock driver])
fi