summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-03-22 14:01:49 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-03-22 14:01:49 +0000
commit3f432fbd018ee684a4f6e760eff901ea463ccb0b (patch)
tree5a18ac85ab25e0b6bd3add3f7f974151c2012564 /c/src/lib/libbsp/i386/pc386/configure.ac
parentFix package name. (diff)
downloadrtems-3f432fbd018ee684a4f6e760eff901ea463ccb0b.tar.bz2
2008-03-22 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, startup/exit.c: Add BSP_PRESS_KEY_FOR_RESET configuration option. When this is set to one, a clean exit of an application will result in the BSP resetting the hardware without waiting for a human to press a key. * start/start.S, startup/linkcmds: Replace the linkcmds with a version very closely based upon the default in binutils 2.18 for this target. This eliminated weird failures with C++ dtors even in C applications. We had an extra _ on a symbol used in start.S.
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/configure.ac')
-rw-r--r--c/src/lib/libbsp/i386/pc386/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/configure.ac b/c/src/lib/libbsp/i386/pc386/configure.ac
index 9bb92a9f7b..81d91a244c 100644
--- a/c/src/lib/libbsp/i386/pc386/configure.ac
+++ b/c/src/lib/libbsp/i386/pc386/configure.ac
@@ -40,6 +40,13 @@ RTEMS_BSPOPTS_HELP([IDE_USE_SECONDARY_INTERFACE],
- and you have at least one disk attached to this interface
- and you do want to access disks attached to this interface])
+#define BSP_PRESS_KEY_FOR_RESET 1
+RTEMS_BSPOPTS_SET([BSP_PRESS_KEY_FOR_RESET],[*],[1])
+RTEMS_BSPOPTS_HELP([BSP_PRESS_KEY_FOR_RESET],
+[Determines, whether this BSP will wait for a key to be pressed
+ before rebooting the PC. This is useful for unattended PC deployments
+])
+
## if this is an i386, does gas have good code16 support?
RTEMS_I386_GAS_CODE16
AM_CONDITIONAL(RTEMS_GAS_CODE16,[test "$RTEMS_GAS_CODE16" = "yes"])