summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/configure.ac
diff options
context:
space:
mode:
authorJan Dolezal <dolezj21@fel.cvut.cz>2014-11-20 15:00:33 +0100
committerGedare Bloom <gedare@rtems.org>2014-11-20 09:52:40 -0500
commit067da5c45dcd6c45a44630795dc702e32112c53c (patch)
tree1f42f32b958a654e11101b38fbfbae428b373ea5 /c/src/lib/libbsp/i386/pc386/configure.ac
parenti386/pc386/include: header files for VESA BIOS EXTENSIONS and VESA Extended D... (diff)
downloadrtems-067da5c45dcd6c45a44630795dc702e32112c53c.tar.bz2
i386/pc386: VESA based frame buffer utilizing real mode interrupt 10h
Diffstat (limited to 'c/src/lib/libbsp/i386/pc386/configure.ac')
-rw-r--r--c/src/lib/libbsp/i386/pc386/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/configure.ac b/c/src/lib/libbsp/i386/pc386/configure.ac
index ecec056bff..a74d6cbc3c 100644
--- a/c/src/lib/libbsp/i386/pc386/configure.ac
+++ b/c/src/lib/libbsp/i386/pc386/configure.ac
@@ -82,6 +82,19 @@ RTEMS_BSPOPTS_HELP([USE_CIRRUS_GD5446],
NOTE: This has only been tested on Qemu.])
AM_CONDITIONAL(USE_CIRRUS_GD5446,test "$USE_CIRRUS_GD5446" = "1")
+RTEMS_BSPOPTS_SET([USE_VBE_RM],[*],[0])
+RTEMS_BSPOPTS_HELP([USE_VBE_RM],
+[If defined, enables use of the Vesa Bios Extensions - real mode interface,
+ which enables graphical mode and introduce it upon bootup.])
+AM_CONDITIONAL(USE_VBE_RM,test "$USE_VBE_RM" = "1")
+
+if test "${USE_VBE_RM}" = "1" ; then
+ if test -z "${NUM_APP_DRV_GDT_DESCRIPTORS}"; then
+ NUM_APP_DRV_GDT_DESCRIPTORS=2 ;
+ else
+ NUM_APP_DRV_GDT_DESCRIPTORS+=2 ;
+ fi
+fi
RTEMS_BSPOPTS_SET([NUM_APP_DRV_GDT_DESCRIPTORS],[*],[0])
RTEMS_BSPOPTS_HELP([NUM_APP_DRV_GDT_DESCRIPTORS],
[Defines how many descriptors in GDT may be allocated for application or