summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-10-17 08:04:01 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-10-17 08:04:01 +0000
commit8d62d94aea76a77cc2cc856aad08925b213e09fb (patch)
treed92fe801fd0ac70da9abf314ffddcb607cadd024 /c/src/lib/libbsp/i386/pc386/Makefile.am
parent2005-10-16 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-8d62d94aea76a77cc2cc856aad08925b213e09fb.tar.bz2
2005-10-17 Ralf Corsepius <ralf.corsepius@rtems.org>
* Makefile.am: Install/preinstall headers from ../../i386/shared.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i386/pc386/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/Makefile.am b/c/src/lib/libbsp/i386/pc386/Makefile.am
index a1c5cc869a..1ced18f628 100644
--- a/c/src/lib/libbsp/i386/pc386/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/Makefile.am
@@ -24,6 +24,10 @@ noinst_PROGRAMS =
SUBDIRS = . tools
+include_bspdir = $(includedir)/bsp
+include_bsp_HEADERS = ../../i386/shared/irq/irq.h \
+ ../../i386/shared/irq/irq_asm.h
+
include_HEADERS += include/crt.h
nodist_include_HEADERS += ../../shared/include/coverhd.h
@@ -60,6 +64,7 @@ include_rtems_HEADERS = console/keyboard.h console/kd.h \
console/serial_mouse.h console/ps2_drv.h console/fb_vga.h
noinst_PROGRAMS += console.rel
+include_HEADERS += ../../i386/shared/comm/i386_io.h
console_rel_SOURCES = console/console.c console/inch.c console/outch.c \
console/defkeymap.c console/fb_vga.c console/keyboard.c \
console/mouse_parser.c console/pc_keyb.c console/ps2_mouse.c \
@@ -81,11 +86,13 @@ gnat_rel_CPPFLAGS = $(AM_CPPFLAGS)
gnat_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
noinst_PROGRAMS += pci.rel
+include_HEADERS += ../../i386/shared/pci/pcibios.h
pci_rel_SOURCES = ../../i386/shared/pci/pcibios.c
pci_rel_CPPFLAGS = $(AM_CPPFLAGS)
pci_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
noinst_PROGRAMS += startup.rel
+include_HEADERS += ../../i386/shared/comm/uart.h
startup_rel_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
startup/bspstart.c startup/exit.c ../../i386/shared/irq/idt.c \
../../i386/shared/irq/irq.c ../../i386/shared/irq/irq_init.c \
@@ -179,6 +186,19 @@ $(PROJECT_INCLUDE)/bspopts.h: include/bspopts.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bspopts.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/bspopts.h
+$(PROJECT_INCLUDE)/bsp/$(dirstamp):
+ @$(mkdir_p) $(PROJECT_INCLUDE)/bsp
+ @: > $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+
+$(PROJECT_INCLUDE)/bsp/irq.h: ../../i386/shared/irq/irq.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/irq.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/irq.h
+
+$(PROJECT_INCLUDE)/bsp/irq_asm.h: ../../i386/shared/irq/irq_asm.h $(PROJECT_INCLUDE)/bsp/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/bsp/irq_asm.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/bsp/irq_asm.h
+
$(PROJECT_INCLUDE)/crt.h: include/crt.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/crt.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/crt.h
@@ -224,6 +244,18 @@ $(PROJECT_INCLUDE)/rtems/fb_vga.h: console/fb_vga.h $(PROJECT_INCLUDE)/rtems/$(d
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/fb_vga.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/fb_vga.h
+$(PROJECT_INCLUDE)/i386_io.h: ../../i386/shared/comm/i386_io.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/i386_io.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/i386_io.h
+
+$(PROJECT_INCLUDE)/pcibios.h: ../../i386/shared/pci/pcibios.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/pcibios.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/pcibios.h
+
+$(PROJECT_INCLUDE)/uart.h: ../../i386/shared/comm/uart.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/uart.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/uart.h
+
if HAS_NETWORKING
$(PROJECT_INCLUDE)/wd80x3.h: include/wd80x3.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/wd80x3.h