summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/Makefile.am
diff options
context:
space:
mode:
authorJan Dolezal <dolezj21@fel.cvut.cz>2015-05-23 12:32:00 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2015-05-26 11:26:46 -0500
commit56399c3bc8b924b5e9266fd73b5b4eed0746adf3 (patch)
treee718bfd8db3bfff7a3300f5b4f61b2955fd28ace /c/src/lib/libbsp/i386/pc386/Makefile.am
parentMerge branch 'master' of ssh://dispatch.rtems.org/data/git/rtems (diff)
downloadrtems-56399c3bc8b924b5e9266fd73b5b4eed0746adf3.tar.bz2
i386/pc386/VESA framebuffer driver: modified and extended initialization options
driver is not initialized by default initialization is possible through multiboot command line option or through the string variable (see fb_default_mode.h) set in user's module allowing the driver to evaluate this variable after the two modules are linked together
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i386/pc386/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/Makefile.am b/c/src/lib/libbsp/i386/pc386/Makefile.am
index 1da40f2e32..56272e26bf 100644
--- a/c/src/lib/libbsp/i386/pc386/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/Makefile.am
@@ -96,6 +96,7 @@ libbsp_a_SOURCES += console/vt.c
libbsp_a_SOURCES += console/videoAsm.S
libbsp_a_SOURCES += console/kbd_parser.c
libbsp_a_SOURCES += console/vgacons.c
+include_bsp_HEADERS += console/fb_default_mode.h
if USE_VBE_RM
include_bsp_HEADERS += include/vbe3.h
include_HEADERS += include/edid.h