summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/pc386/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2016-03-02 13:25:13 -0600
committerJoel Sherrill <joel@rtems.org>2016-03-10 10:26:48 -0600
commit12c9dc8ff5ad2e1226562474600a5abe8c2e575d (patch)
tree50c652446c8674b72317626dc39e41b085f94d96 /c/src/lib/libbsp/i386/pc386/Makefile.am
parentlibtests/syscall01: Explicitly request close (diff)
downloadrtems-12c9dc8ff5ad2e1226562474600a5abe8c2e575d.tar.bz2
pc386: Eliminate pcibios.h and begin removal obsolete PCI BIOS API uses
This first step eliminates the following as public APIs for the pc386 BSP: + pcib_conf_read8 + pcib_conf_read16 + pcib_conf_read32 + pcib_conf_write8 + pcib_conf_write16 + pcib_conf_write32 The if_fxp.c driver uses these enough where I provided local macros to allow the code to be mostly unmodified. On other architectures these names have been used privately. It will take multiple patches to completely eliminate these symbols from the RTEMS source tree. The focus of the first effort is just to eliminate these as a public pc386 API so support can be added for systems without legacy PCI BIOS.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/i386/pc386/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/i386/pc386/Makefile.am b/c/src/lib/libbsp/i386/pc386/Makefile.am
index 1d52cf411d..a9c645bb67 100644
--- a/c/src/lib/libbsp/i386/pc386/Makefile.am
+++ b/c/src/lib/libbsp/i386/pc386/Makefile.am
@@ -139,10 +139,8 @@ libbsp_a_SOURCES += ../../i386/shared/comm/gdb_glue.c
# gnat
libbsp_a_SOURCES += ../../shared/gnatinstallhandler.c
-include_HEADERS += ../../i386/shared/pci/pcibios.h
# pci
-libbsp_a_SOURCES += ../../i386/shared/pci/pcibios.c \
- ../../i386/shared/pci/pcibios.h
+libbsp_a_SOURCES += ../../i386/shared/pci/pcibios.c
include_HEADERS += ../../i386/shared/comm/uart.h
# startup