summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/i386ex/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:50:45 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:50:45 +0000
commitbc2f04f8a8192e148ca9832c49c1c73a445f4310 (patch)
tree12dc7cb8f8eb044a52ba59ee466823066e215513 /c/src/lib/libbsp/i386/i386ex/Makefile.am
parentPatch rtems-rc-20000104-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-bc2f04f8a8192e148ca9832c49c1c73a445f4310.tar.bz2
Patch rtems-rc-20000104-13.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which does the following: * some cleanups, fixes, addtions to the libbsp automake transition patches * The missing Automake transistion patches all libcpu/<cpu>/<variant>/* previously not yet been converted to automake (libcpu/powerpc, libcpu/hppa1.1, libcpu/mips64orion, libcpu/sparc) => With this patch, libcpu/*/* is under full automake control. NOTES: * This patch is tested by building for random set of bsps affected by this patch, but not tested for all BSPs. * The parts of this patch related to libcpu/powerpc fix many small bugs inside of those Makefiles. * Have a look into libcpu/powerpc/mpc6xx/, which is in rather bad shape, IMO. Obviously most subdirectories seem to be build but are not included into libcpu.a by wrapup/Makefile. Addtionally, no actual BSP uses this cpu-variant subdirectory. Furthermore libcpu/powerpc/mpc6xx has a different directory layout than all other powerpc/<variant>/ directories. Joel's note: I agree but the issue is that there is a conflict between including timer or clock in libcpu/XXX/wrapup/Makefile.* and letting a BSP specifically decide to pick it up. There is no clear solution to this at the moment.
Diffstat (limited to 'c/src/lib/libbsp/i386/i386ex/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/i386ex/Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/i386/i386ex/Makefile.am b/c/src/lib/libbsp/i386/i386ex/Makefile.am
index a9626075ee..0bc7c07a45 100644
--- a/c/src/lib/libbsp/i386/i386ex/Makefile.am
+++ b/c/src/lib/libbsp/i386/i386ex/Makefile.am
@@ -5,14 +5,9 @@
AUTOMAKE_OPTIONS = foreign 1.4
ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
-if HAS_NETWORKING
-# We only build the Network library if HAS_NETWORKING was defined
-NETWORK = network
-endif
-
# wrapup is the one that actually builds and installs the library
# from the individual .rel files built in other directories
-SUBDIRS = . include start startup clock console timer $(NETWORK) wrapup
+SUBDIRS = . include start startup clock console timer network wrapup
include $(top_srcdir)/../../bsp.am