summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/i386/i386ex/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:31:16 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:31:16 +0000
commit5fa147949dc75b98a52ccfa1a585b91fd0026bb5 (patch)
tree2851115d656a4e14820e2b5f3bbff8f2916f928d /c/src/lib/libbsp/i386/i386ex/Makefile.am
parentPatch rtems-rc-20000104-10.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-5fa147949dc75b98a52ccfa1a585b91fd0026bb5.tar.bz2
Patch rtems-rc-20000104-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the i386 directory to automake. NOTE: Ralf is unable to build any i386 BSPs. This was true before and after this patch and appears (to Joel) to be a tool issue unrelated since others can build i386 BSPs.
Diffstat (limited to 'c/src/lib/libbsp/i386/i386ex/Makefile.am')
-rw-r--r--c/src/lib/libbsp/i386/i386ex/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/i386/i386ex/Makefile.am b/c/src/lib/libbsp/i386/i386ex/Makefile.am
new file mode 100644
index 0000000000..a9626075ee
--- /dev/null
+++ b/c/src/lib/libbsp/i386/i386ex/Makefile.am
@@ -0,0 +1,22 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+if HAS_NETWORKING
+# We only build the Network library if HAS_NETWORKING was defined
+NETWORK = network
+endif
+
+# wrapup is the one that actually builds and installs the library
+# from the individual .rel files built in other directories
+SUBDIRS = . include start startup clock console timer $(NETWORK) wrapup
+
+include $(top_srcdir)/../../bsp.am
+
+EXTRA_DIST = bsp_specs
+
+include $(top_srcdir)/../../../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../../../automake/local.am