summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/hppa1.1/simhppa/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-09-26 21:38:59 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-09-26 21:38:59 +0000
commitee5171b968d87e2807608c64c8a2692d69299ff4 (patch)
tree8c5b25454afb686ce313316bc700d06e27d27c78 /c/src/lib/libbsp/hppa1.1/simhppa/wrapup/Makefile.am
parent2003-09-26 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-ee5171b968d87e2807608c64c8a2692d69299ff4.tar.bz2
2003-09-26 Joel Sherrill <joel@OARcorp.com>
* hppa1.1/.cvsignore, hppa1.1/ChangeLog, hppa1.1/Makefile.am, hppa1.1/acinclude.m4, hppa1.1/configure.ac, hppa1.1/simhppa/.cvsignore, hppa1.1/simhppa/ChangeLog, hppa1.1/simhppa/Makefile.am, hppa1.1/simhppa/bsp_specs, hppa1.1/simhppa/configure.ac, hppa1.1/simhppa/times, hppa1.1/simhppa/include/.cvsignore, hppa1.1/simhppa/include/Makefile.am, hppa1.1/simhppa/include/bsp.h, hppa1.1/simhppa/include/ttydrv.h, hppa1.1/simhppa/shmsupp/.cvsignore, hppa1.1/simhppa/shmsupp/Makefile.am, hppa1.1/simhppa/shmsupp/README, hppa1.1/simhppa/shmsupp/addrconv.c, hppa1.1/simhppa/shmsupp/cause_intr.c, hppa1.1/simhppa/shmsupp/getcfg.c, hppa1.1/simhppa/shmsupp/lock.c, hppa1.1/simhppa/shmsupp/mpisr.c, hppa1.1/simhppa/start/.cvsignore, hppa1.1/simhppa/start/Makefile.am, hppa1.1/simhppa/start/start.S, hppa1.1/simhppa/startup/.cvsignore, hppa1.1/simhppa/startup/Makefile.am, hppa1.1/simhppa/startup/bspclean.c, hppa1.1/simhppa/startup/bspstart.c, hppa1.1/simhppa/startup/linkcmds, hppa1.1/simhppa/startup/setvec.c, hppa1.1/simhppa/tools/.cvsignore, hppa1.1/simhppa/tools/ChangeLog, hppa1.1/simhppa/tools/Makefile.am, hppa1.1/simhppa/tools/configure.ac, hppa1.1/simhppa/tools/print_dump.c, hppa1.1/simhppa/tty/.cvsignore, hppa1.1/simhppa/tty/Makefile.am, hppa1.1/simhppa/tty/tty.c, hppa1.1/simhppa/wrapup/.cvsignore, hppa1.1/simhppa/wrapup/Makefile.am: Removed.
Diffstat (limited to 'c/src/lib/libbsp/hppa1.1/simhppa/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/hppa1.1/simhppa/wrapup/Makefile.am37
1 files changed, 0 insertions, 37 deletions
diff --git a/c/src/lib/libbsp/hppa1.1/simhppa/wrapup/Makefile.am b/c/src/lib/libbsp/hppa1.1/simhppa/wrapup/Makefile.am
deleted file mode 100644
index 9f2e253905..0000000000
--- a/c/src/lib/libbsp/hppa1.1/simhppa/wrapup/Makefile.am
+++ /dev/null
@@ -1,37 +0,0 @@
-##
-## $Id$
-##
-
-# pieces to pick up out of libcpu/hppa
-CPU_FILES = clock milli timer
-
-if HAS_MP
-GENERIC_MP_REL_FILES = shmdr
-endif
-GENERIC_FILES = $(GENERIC_MP_REL_FILES)
-
-if HAS_MP
-BSP_MP_O_FILES = shmsupp
-endif
-BSP_FILES = startup tty $(BSP_MP_O_FILES)
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_FILES), $(wildcard ../$(piece)/$(ARCH)/*.$(OBJEXT))) \
- $(foreach piece, $(CPU_FILES), ../../../../libcpu/$(RTEMS_CPU)/$(piece)/$(ARCH)/$(piece).rel) \
- $(foreach piece, $(GENERIC_FILES), ../../../$(piece)/$(ARCH)/$(piece).rel)
-
-LIB = $(ARCH)/libbsp.a
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(LIB): $(OBJS)
- $(make-library)
-
-all-local: $(ARCH) $(LIB)
-
-include $(top_srcdir)/../../../../automake/local.am