summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-08 13:47:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-08 13:47:09 +0000
commit9f70652bc9c83b069857abc36e2a4154430a7537 (patch)
tree864e3798e5cdd385451427e4878a90d106d92c18 /c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
parent2001-05-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-9f70652bc9c83b069857abc36e2a4154430a7537.tar.bz2
2001-05-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Add bspopts.h. * include/.cvsignore: Add bspopts.h*, stamp-h*. * include/Makefile.am: Use *_HEADERS instead of *H_FILES. * include/bsp.h: Include bspopts.h.
Diffstat (limited to 'c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am b/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
index d2abb7f5c7..ab7871aeb5 100644
--- a/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
+++ b/c/src/lib/libbsp/hppa1.1/simhppa/include/Makefile.am
@@ -4,9 +4,9 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = bsp.h ../../../shared/include/coverhd.h
-
-RTEMS_H_FILES = ttydrv.h
+include_rtemsdir = $(includedir)/rtems
+include_HEADERS = bsp.h coverhd.h bspopts.h
+include_rtems_HEADERS = ttydrv.h
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -14,21 +14,21 @@ $(PROJECT_INCLUDE):
$(PROJECT_INCLUDE)/rtems:
$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/bsp.h: bsp.h
+$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-$(PROJECT_INCLUDE)/coverhd.h: ../../../shared/include/coverhd.h
+coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
$(INSTALL_DATA) $< $@
+CLEANFILES += coverhd.h
-$(PROJECT_INCLUDE)/rtems/ttydrv.h: ttydrv.h
+$(PROJECT_INCLUDE)/rtems/%.h: %.h
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
- $(PROJECT_INCLUDE)/coverhd.h $(PROJECT_INCLUDE)/rtems \
- $(PROJECT_INCLUDE)/rtems/ttydrv.h
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) \
+ $(include_HEADERS:%=%(PROJECT_INCLUDE)/%) \
+ $(PROJECT_INCLUDE)/rtems \
+ $(include_HEADERS:%=%(PROJECT_INCLUDE)/rtems/%)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = bsp.h ttydrv.h
-
include $(top_srcdir)/../../../../../../automake/local.am