summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/hppa1.1/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:23:56 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:23:56 +0000
commit53ab4823e082a13e7e59d737813394f846b82fc2 (patch)
tree133c2fbd6e8028ce1076f85e74f63022a70a582a /c/src/lib/libbsp/hppa1.1/configure.in
parentPatch rtems-rc-20000104-7.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-53ab4823e082a13e7e59d737813394f846b82fc2.tar.bz2
Patch rtems-rc-20000104-9.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the hppa1.1 directory to automake. NOTE: * Due to not having a toolchain (gcc refuses to build) this patch is untested. * I omited/deactivated the pxfl subdirectory, because I don't understand how it supposed to work. Joel's note: It was right to ignore the pxfl directory. It should be removed one the BSPs are moved outside the tree. This was an old hack.
Diffstat (limited to 'c/src/lib/libbsp/hppa1.1/configure.in')
-rw-r--r--c/src/lib/libbsp/hppa1.1/configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/hppa1.1/configure.in b/c/src/lib/libbsp/hppa1.1/configure.in
new file mode 100644
index 0000000000..eead2adc73
--- /dev/null
+++ b/c/src/lib/libbsp/hppa1.1/configure.in
@@ -0,0 +1,26 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(simhppa)
+RTEMS_TOP(../../../../..)
+AC_CONFIG_AUX_DIR(../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libbsp-hppa1.1,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+RTEMS_PROJECT_ROOT
+
+RTEMS_BSP_ALIAS(${RTEMS_BSP},bspdir)
+AC_CONFIG_SUBDIRS($bspdir)
+
+# try to explicitly list a Makefile here
+AC_OUTPUT(
+Makefile)