summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/h8300/h8sim/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-10-15 09:31:03 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-10-15 09:33:16 -0500
commite6386f7764882c0052a4a96c458e4b20cd23a834 (patch)
tree50df92b7a3db986b915d4e6c53222697bf902d83 /c/src/lib/libbsp/h8300/h8sim/Makefile.am
parenth8300/h8sim/startup/__main.c: Removed. Obsolete remnant of COFF. (diff)
downloadrtems-e6386f7764882c0052a4a96c458e4b20cd23a834.tar.bz2
h8300/h8sim: Exit simulator cleanly
Diffstat (limited to 'c/src/lib/libbsp/h8300/h8sim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/h8300/h8sim/Makefile.am23
1 files changed, 15 insertions, 8 deletions
diff --git a/c/src/lib/libbsp/h8300/h8sim/Makefile.am b/c/src/lib/libbsp/h8300/h8sim/Makefile.am
index 19f473a22d..3d36374688 100644
--- a/c/src/lib/libbsp/h8300/h8sim/Makefile.am
+++ b/c/src/lib/libbsp/h8300/h8sim/Makefile.am
@@ -26,17 +26,24 @@ noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
# startup
-libbsp_a_SOURCES += ../../shared/bspclean.c ../../shared/bsplibc.c \
- ../../shared/bsppredriverhook.c ../../shared/bsppretaskinghook.c \
- ../../shared/bspgetworkarea.c ../../shared/bsppost.c \
- ../../shared/bspstart.c startup/h8bdinstallirq.c \
- ../../shared/bootcard.c ../../shared/sbrk.c \
- ../../shared/gnatinstallhandler.c startup/__main.c
+libbsp_a_SOURCES += ../../shared/bspclean.c
+libbsp_a_SOURCES += ../../shared/bsplibc.c
+libbsp_a_SOURCES += ../../shared/bsppredriverhook.c
+libbsp_a_SOURCES += ../../shared/bsppretaskinghook.c
+libbsp_a_SOURCES += ../../shared/bspgetworkarea.c
+libbsp_a_SOURCES += ../../shared/bsppost.c
+libbsp_a_SOURCES += ../../shared/bspstart.c
+libbsp_a_SOURCES += startup/h8bdinstallirq.c
+libbsp_a_SOURCES += ../../shared/bootcard.c
+libbsp_a_SOURCES += ../../shared/sbrk.c
+libbsp_a_SOURCES += ../../shared/gnatinstallhandler.c
+
# clock
libbsp_a_SOURCES += ../../shared/clock_driver_simidle.c
# console
-libbsp_a_SOURCES += ../../shared/console-polled.c console/console-io.c \
- console/syscalls.S
+libbsp_a_SOURCES += ../../shared/console-polled.c
+libbsp_a_SOURCES += console/console-io.c
+libbsp_a_SOURCES += console/syscalls.S
# timer
libbsp_a_SOURCES += ../../shared/timerstub.c