summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/epiphany/configure.ac
diff options
context:
space:
mode:
authorHesham ALMatary <heshamelmatary@gmail.com>2015-05-21 17:53:53 +0100
committerGedare Bloom <gedare@rtems.org>2015-05-21 16:03:34 -0400
commit6f71dcb7cdaff53d8b44ea7c13ddb48d274663e7 (patch)
tree8854c63e9a514b4b9c1e7e5fb4b166d165e6025b /c/src/lib/libbsp/epiphany/configure.ac
parentcpukit: Add Epiphany architecture port v4 (diff)
downloadrtems-6f71dcb7cdaff53d8b44ea7c13ddb48d274663e7.tar.bz2
Epiphany: Add the first epiphany_sim BSP v4
This BSP in intended to run on the simulator that should be built from RSB. When building RTEMS for Epiphany --disable-networking must be provided part of the configure command.
Diffstat (limited to 'c/src/lib/libbsp/epiphany/configure.ac')
-rw-r--r--c/src/lib/libbsp/epiphany/configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/epiphany/configure.ac b/c/src/lib/libbsp/epiphany/configure.ac
new file mode 100644
index 0000000000..bba5440ca9
--- /dev/null
+++ b/c/src/lib/libbsp/epiphany/configure.ac
@@ -0,0 +1,19 @@
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([rtems-c-src-lib-libbsp-epiphany],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([epiphany_sim])
+RTEMS_TOP(../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define foreign subdir-objects 1.12.2])
+AM_MAINTAINER_MODE
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_PROJECT_ROOT
+
+RTEMS_CHECK_BSPDIR([$RTEMS_BSP_FAMILY])
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT