summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 14:07:47 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 14:07:47 +0000
commit4ca704ce3de14b207f7d90da1ebef6e956d32303 (patch)
tree558ef7440df403f6468a52169804adf7d41ef48b /c/src/lib/libbsp/c4x/c4xsim/Makefile.am
parent2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-4ca704ce3de14b207f7d90da1ebef6e956d32303.tar.bz2
2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org>
* Makefile.am: Eliminate bsp.am. Build startup files as side-effect of building libbspstart.a, using automake-rules.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/c4x/c4xsim/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/c4x/c4xsim/Makefile.am b/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
index e356e88cae..97552374c1 100644
--- a/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
+++ b/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
@@ -9,7 +9,6 @@ ACLOCAL_AMFLAGS = -I ../../../../aclocal
SUBDIRS = . tools
include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../bsp.am
dist_project_lib_DATA = bsp_specs
@@ -22,14 +21,13 @@ DISTCLEANFILES = include/bspopts.h
include_HEADERS += include/simio.h
nodist_include_HEADERS += ../../shared/include/coverhd.h
-EXTRA_DIST = start/start.S
-start.$(OBJEXT): start/start.S
- $(CPPASCOMPILE) -o $@ -c $<
+noinst_LIBRARIES = libbspstart.a
+libbspstart_a_SOURCES = start/start.S
project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds
-noinst_LIBRARIES = libbsp.a
+noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
# startup
@@ -50,7 +48,7 @@ libbsp_a_SOURCES += console/debugio.c
# timer
libbsp_a_SOURCES += timer/timer.c
-EXTRA_DIST += times
+EXTRA_DIST = times
include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../../automake/local.am