summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-19 15:50:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-19 15:50:44 +0000
commit0dba2a55d7d89c20d119b0f15eaf0d696cdff7c0 (patch)
treed365e3842fb5b0b6b8f326908518a9d4b6976710 /c/src/lib/libbsp/c4x/c4xsim/Makefile.am
parent2008-09-19 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-0dba2a55d7d89c20d119b0f15eaf0d696cdff7c0.tar.bz2
2008-09-19 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, console/debugio.c: Split out bspstart contents. Use shared stub for bsp_start. * startup/bsppretaskinghook.c: New file. * startup/bspstart.c: Removed.
Diffstat (limited to 'c/src/lib/libbsp/c4x/c4xsim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/c4x/c4xsim/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/c4x/c4xsim/Makefile.am b/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
index 1595cb40db..7ed079805a 100644
--- a/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
+++ b/c/src/lib/libbsp/c4x/c4xsim/Makefile.am
@@ -33,7 +33,7 @@ dist_project_lib_DATA += startup/linkcmds
startup_SOURCES = ../../shared/bspclean.c ../../shared/bsplibc.c \
../../shared/bsppredriverhook.c ../../shared/bspgetworkarea.c \
- ../../shared/bsppost.c startup/bspstart.c \
+ ../../shared/bsppost.c startup/bsppretaksinghook.c ../../shared/bspstart.c \
../../shared/bootcard.c ../../shared/sbrk.c ../../shared/setvec.c \
../../c4x/shared/c3xspurious.c ../../c4x/shared/c4xspurious.c \
../../c4x/shared/bspspuriousinit.c startup/spurious.c \
@@ -41,11 +41,12 @@ startup_SOURCES = ../../shared/bspclean.c ../../shared/bsplibc.c \
clock_SOURCES = clock/clock.c
console_SOURCES = console/consolereserveresources.c console/debugio.c \
console/simio.c ../../shared/console.c
+debugio_SOURCES = console/debugio.c
timer_SOURCES = timer/timer.c
noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) $(console_SOURCES) \
- $(timer_SOURCES)
+ $(debugio_SOURCES) $(timer_SOURCES)
EXTRA_DIST += times