summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/bfin/bf537Stamp/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-08-15 20:21:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-08-15 20:21:00 +0000
commit61f8fb0e3d35c1da13d6a429d68cc694517095de (patch)
tree05b9f933d56e6e362a55aa9ac85722093eeb6450 /c/src/lib/libbsp/bfin/bf537Stamp/configure.ac
parent2008-08-15 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-61f8fb0e3d35c1da13d6a429d68cc694517095de.tar.bz2
2008-08-15 Allan Hessenflow <allanh@kallisti.com>
* ChangeLog, Makefile.am, README, bsp_specs, configure.ac, preinstall.am, console/console.c, include/bsp.h, network/networkconfig.c, start/start.S, startup/bspstart.c, startup/linkcmds: New files.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/bfin/bf537Stamp/configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/bfin/bf537Stamp/configure.ac b/c/src/lib/libbsp/bfin/bf537Stamp/configure.ac
new file mode 100644
index 0000000000..37c5e05c0d
--- /dev/null
+++ b/c/src/lib/libbsp/bfin/bf537Stamp/configure.ac
@@ -0,0 +1,29 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+##
+
+AC_PREREQ(2.60)
+AC_INIT([rtems-c-src-lib-libbsp-bfin-bf537Stamp],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define nostdinc foreign 1.10])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
+
+RTEMS_CHECK_NETWORKING
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+
+## bsp-specific options
+RTEMS_BSPOPTS_SET([CONSOLE_USE_INTERRUPTS],[*],[0])
+RTEMS_BSPOPTS_HELP([CONSOLE_USE_INTERRUPTS],
+[The console driver can operate in either polled or interrupt mode.])
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT