summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/bare/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-13 16:02:57 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-13 16:02:57 +0000
commitad0c286463e0f32be96924b9c138473429d91d73 (patch)
tree08b10642baff3c4b32fe2aa54d4be3a41e9d4b55 /c/src/lib/libbsp/bare/Makefile.am
parentPatch rtems-rc-19991203-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ad0c286463e0f32be96924b9c138473429d91d73.tar.bz2
Patch rtems-rc-19991203-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
which adds automake support to libbsp/bare.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/bare/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/bare/Makefile.am b/c/src/lib/libbsp/bare/Makefile.am
new file mode 100644
index 0000000000..d8a5abe2d3
--- /dev/null
+++ b/c/src/lib/libbsp/bare/Makefile.am
@@ -0,0 +1,24 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+include $(top_srcdir)/../bsp.am
+
+SUBDIRS = . include
+
+$(PROJECT_RELEASE)/bsp_specs: bsp_specs
+ $(INSTALL_DATA) $< $@
+
+PREINSTALL_FILES += \
+$(PROJECT_RELEASE)/bsp_specs
+
+all-local : $(PREINSTALL_FILES)
+
+EXTRA_DIST = \
+build-tools bsp_specs do-bare-bsp-build
+
+include $(top_srcdir)/../../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../../automake/local.am