summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/tms570/Makefile.am
diff options
context:
space:
mode:
authorPremysl Houdek <kom541000@gmail.com>2015-07-16 15:26:09 +0100
committerJoel Sherrill <joel.sherrill@oarcorp.com>2015-07-16 09:31:09 -0700
commitbea49c94773ebe6c5454a4ed48c2fed28c922d30 (patch)
tree91f22424458d95ca4d2988f4065ab0bb3aebaf94 /c/src/lib/libbsp/arm/tms570/Makefile.am
parentremaining bsp.h: Fix by hand to LIBBSP_@CPU@_@BSP_FAMILY@_BSP_H (diff)
downloadrtems-bea49c94773ebe6c5454a4ed48c2fed28c922d30.tar.bz2
bsp/tms570: New/generated header files for TMS570 SoC peripherals registers.
The header files are generated by script make_header.py. Current script's version can be found at: https://github.com/AoLaD/rtems-tms570-utils/tree/headers/headers/python Registers offsets and fields have been extracted from reference manual. Signed-off-by: Premysl Houdek <kom541000@gmail.com>
Diffstat (limited to 'c/src/lib/libbsp/arm/tms570/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/tms570/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/tms570/Makefile.am b/c/src/lib/libbsp/arm/tms570/Makefile.am
index 6cad609480..b9c7fd4f14 100644
--- a/c/src/lib/libbsp/arm/tms570/Makefile.am
+++ b/c/src/lib/libbsp/arm/tms570/Makefile.am
@@ -11,6 +11,8 @@ include $(top_srcdir)/../../../../automake/compile.am
include_bspdir = $(includedir)/bsp
+include_bsp_ti_herculesdir = $(includedir)/bsp/ti_herc
+
dist_project_lib_DATA = bsp_specs
# ----------------------------
@@ -40,6 +42,43 @@ include_bsp_HEADERS += include/tms570-pom.h
include_bsp_HEADERS += include/tms570-sci-driver.h
include_bsp_HEADERS += include/system-clocks.h
+include_bsp_ti_hercules_HEADERS = include/ti_herc/reg_adc.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_ccmsr.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_crc.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_dcan.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_dcc.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_dma.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_dmm.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_efuse.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_emac.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_emacm.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_emif.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_esm.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_flash.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_flex_ray.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_gio.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_htu.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_i2c.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_iomm.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_lin.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_mdio.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_n2het.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_pbist.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_pll.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_pmm.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_rti.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_rtp.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_sci.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_tcr.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_tcram.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_vim.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_pom.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_spi.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_stc.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_sys.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_sys2.h
+include_bsp_ti_hercules_HEADERS += include/ti_herc/reg_pcr.h
+
include_HEADERS += ../../shared/include/tm27.h
# ----------------------------