summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/smdk2410/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:49:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:49:29 +0000
commitd8a64319069697a0e8e6f397d2bd6badddf669a5 (patch)
tree7e8886f62b5f161047c32084de24629d917a3585 /c/src/lib/libbsp/arm/smdk2410/Makefile.am
parent2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-d8a64319069697a0e8e6f397d2bd6badddf669a5.tar.bz2
2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, include/bspopts.h.in: Use standardized bsp_cleanup() which can optionally print a message, poll for user to press key, and call bsp_reset(). Using this eliminates the various bsp_cleanup() implementations which had their own implementation and variety of string constants.
Diffstat (limited to 'c/src/lib/libbsp/arm/smdk2410/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/smdk2410/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/arm/smdk2410/Makefile.am b/c/src/lib/libbsp/arm/smdk2410/Makefile.am
index 7a562c0ce0..4a31407048 100644
--- a/c/src/lib/libbsp/arm/smdk2410/Makefile.am
+++ b/c/src/lib/libbsp/arm/smdk2410/Makefile.am
@@ -26,7 +26,8 @@ project_lib_DATA = start.$(OBJEXT)
dist_project_lib_DATA += startup/linkcmds
startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
- ../gp32/startup/bspstart.c ../gp32/startup/bspclean.c startup/memmap.c \
+ ../gp32/startup/bspstart.c ../../shared/bspclean.c \
+ ../gp32/startup/bspreset.c startup/memmap.c \
../../shared/bootcard.c ../../shared/sbrk.c \
../../shared/bsppretaskinghook.c \
../../shared/bsppredriverhook.c ../../shared/bspgetworkarea.c \