summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/raspberrypi/configure.ac
diff options
context:
space:
mode:
authorAndre Marques <andre.lousa.marques@gmail.com>2015-09-05 21:53:16 +0100
committerGedare Bloom <gedare@rtems.org>2015-09-25 16:36:52 -0400
commit7aca0fefce41f2090ffbd2f7ee2fbfcc9f2d1f0d (patch)
tree0b21847e289cb557ca0bba23d6b925a967af2864 /c/src/lib/libbsp/arm/raspberrypi/configure.ac
parentAdded GPIO API sources to rpi Makefile (diff)
downloadrtems-7aca0fefce41f2090ffbd2f7ee2fbfcc9f2d1f0d.tar.bz2
RaspberryPi: Added I2C and SPI bus support.
Further documentation can be found in https://devel.rtems.org/wiki/GSoC/2015/RaspberryPi_peripherals_and_SD_card and test data (including sample user applications, device drivers and wiring schemes) can be found in https://github.com/asuol/RTEMS_rpi_testing
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/arm/raspberrypi/configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/arm/raspberrypi/configure.ac b/c/src/lib/libbsp/arm/raspberrypi/configure.ac
index 27abe6c09f..2676bef72e 100644
--- a/c/src/lib/libbsp/arm/raspberrypi/configure.ac
+++ b/c/src/lib/libbsp/arm/raspberrypi/configure.ac
@@ -24,14 +24,18 @@ AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
RTEMS_BSPOPTS_SET([BSP_START_RESET_VECTOR],[*],[])
RTEMS_BSPOPTS_HELP([BSP_START_RESET_VECTOR],[reset vector address for BSP start])
+RTEMS_BSPOPTS_SET([I2C_IO_MODE],[*],[1])
+RTEMS_BSPOPTS_HELP([I2C_IO_MODE],[Define to 1 to use interrupt-driven I/O with the Raspberry Pi I2C bus. If defined to other value the access will be polled-driven.])
+
+RTEMS_BSPOPTS_SET([SPI_IO_MODE],[*],[1])
+RTEMS_BSPOPTS_HELP([SPI_IO_MODE],[Define to 1 to use interrupt-driven I/O with the Raspberry Pi SPI bus. If defined to other value the access will be polled-driven.])
+
# Is this a Raspberry Pi 2?
RTEMS_BSPOPTS_SET([BSP_IS_RPI2],[raspberrypi2],[1])
RTEMS_BSPOPTS_SET([BSP_IS_RPI2],[*],[0])
RTEMS_BSPOPTS_HELP([BSP_IS_RPI2],[Set if the BSP variant is Raspberry Pi 2.])
AM_CONDITIONAL(RTEMS_RPI2,[test "$BSP_IS_RPI2" = "1"])
-
-
RTEMS_BSP_CLEANUP_OPTIONS(0, 0)
RTEMS_BSP_LINKCMDS