summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/raspberrypi/configure.ac
diff options
context:
space:
mode:
authorAlan Cudmore <alan.cudmore@gmail.com>2015-03-15 11:04:06 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2015-03-16 09:43:21 -0500
commit71260b4a092cb4afad3c44bae36c2636059bfd27 (patch)
treecddcac9f0a46d72f46e68e60881d6fe249a064fa /c/src/lib/libbsp/arm/raspberrypi/configure.ac
parenttmtests/tmfine01: New test (diff)
downloadrtems-71260b4a092cb4afad3c44bae36c2636059bfd27.tar.bz2
preliminary Raspberry Pi Model 2 support
This patch adds a BSP variant for the Raspberry Pi 2. You can build both variants by configuring with the option --enable-rtemsbsp="raspberrypi2 raspberrypi" For the current BSP, the only change was the peripheral register base address and the compiler options. The raspberrypi/make/custom rules were re-factored: raspberrypi.inc -- Common rules raspberrypi.cfg -- Raspberry Pi 1 specific rule/optons raspberrypi2.cfg -- Raspberry Pi 2 specific rule/options I tested hello, ticker, unlimited, and paranoia on both the Pi (Model A+) and Pi 2.
Diffstat (limited to 'c/src/lib/libbsp/arm/raspberrypi/configure.ac')
-rw-r--r--c/src/lib/libbsp/arm/raspberrypi/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/raspberrypi/configure.ac b/c/src/lib/libbsp/arm/raspberrypi/configure.ac
index 42be4e9c9c..27abe6c09f 100644
--- a/c/src/lib/libbsp/arm/raspberrypi/configure.ac
+++ b/c/src/lib/libbsp/arm/raspberrypi/configure.ac
@@ -24,6 +24,14 @@ AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
RTEMS_BSPOPTS_SET([BSP_START_RESET_VECTOR],[*],[])
RTEMS_BSPOPTS_HELP([BSP_START_RESET_VECTOR],[reset vector address for BSP start])
+# Is this a Raspberry Pi 2?
+RTEMS_BSPOPTS_SET([BSP_IS_RPI2],[raspberrypi2],[1])
+RTEMS_BSPOPTS_SET([BSP_IS_RPI2],[*],[0])
+RTEMS_BSPOPTS_HELP([BSP_IS_RPI2],[Set if the BSP variant is Raspberry Pi 2.])
+AM_CONDITIONAL(RTEMS_RPI2,[test "$BSP_IS_RPI2" = "1"])
+
+
+
RTEMS_BSP_CLEANUP_OPTIONS(0, 0)
RTEMS_BSP_LINKCMDS