summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/lpc32xx/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2010-05-20 13:15:35 +0000
committerSebastian Huber <sebastian.huber@embedded-brains.de>2010-05-20 13:15:35 +0000
commit4c4974e81f1d8cfcc2677be528144a8e68466873 (patch)
tree51d47e76eedd1168bd35fba51d56024077427bd9 /c/src/lib/libbsp/arm/lpc32xx/Makefile.am
parent2010-05-20 Sebastian Huber <sebastian.huber@embedded-brains.de> (diff)
downloadrtems-4c4974e81f1d8cfcc2677be528144a8e68466873.tar.bz2
2010-05-20 Sebastian Huber <sebastian.huber@embedded-brains.de>
* make/custom/lpc32xx.inc, make/custom/lpc32xx_mzx_boot_int.cfg, startup/linkcmds.lpc32xx_mzx_boot_int: New files. * Makefile.am, configure.ac, preinstall.am, include/bsp.h, include/bspopts.h.in, include/lpc32xx.h, irq/irq.c, make/custom/lpc32xx_phycore.cfg, startup/bspstart.c, startup/bspstarthooks.c: Changes throughout.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/arm/lpc32xx/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/arm/lpc32xx/Makefile.am b/c/src/lib/libbsp/arm/lpc32xx/Makefile.am
index 2f0d476692..69ae723625 100644
--- a/c/src/lib/libbsp/arm/lpc32xx/Makefile.am
+++ b/c/src/lib/libbsp/arm/lpc32xx/Makefile.am
@@ -33,6 +33,7 @@ include_bsp_HEADERS += ../../shared/include/utility.h
include_bsp_HEADERS += ../../shared/include/irq-generic.h
include_bsp_HEADERS += ../../shared/include/irq-info.h
include_bsp_HEADERS += ../../shared/include/stackalloc.h
+include_bsp_HEADERS += ../../shared/include/uart-output-char.h
include_bsp_HEADERS += ../../shared/tod.h
include_bsp_HEADERS += ../shared/include/linker-symbols.h
include_bsp_HEADERS += ../shared/include/start.h
@@ -60,7 +61,8 @@ project_lib_DATA = start.$(OBJEXT)
project_lib_DATA += startup/linkcmds
project_lib_DATA += ../shared/startup/linkcmds.base
-EXTRA_DIST = startup/linkcmds.lpc32xx_phycore
+EXTRA_DIST = startup/linkcmds.lpc32xx_phycore \
+ startup/linkcmds.lpc32xx_mzx_boot_int
###############################################################################
# LibBSP #
@@ -83,6 +85,7 @@ libbsp_a_SOURCES += ../../shared/bootcard.c \
../../shared/gnatinstallhandler.c \
../../shared/sbrk.c \
../../shared/src/stackalloc.c \
+ ../../shared/src/uart-output-char.c \
../shared/abort/simple_abort.c
# Startup