summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/gp32/configure.ac
diff options
context:
space:
mode:
authorJay Monkman <jtm@smoothsmoothie.com>2005-03-11 07:27:56 +0000
committerJay Monkman <jtm@smoothsmoothie.com>2005-03-11 07:27:56 +0000
commite8c785c68aeb6565c1cd56fcefd8edb1163f4894 (patch)
treedd3954615862f25cf1a9e81e455f37f730af7074 /c/src/lib/libbsp/arm/gp32/configure.ac
parent2005-03-11 Philippe Simons <loki_666@fastmail.fm> (diff)
downloadrtems-e8c785c68aeb6565c1cd56fcefd8edb1163f4894.tar.bz2
2005-03-11 Philippe Simons <loki_666@fastmail.fm>
* acinclude.m4: Added gp32 BSP. * gp32/.cvsignore, gp32/Makefile.am, gp32/README, gp32/bsp_specs, gp32/configure.ac, gp32/console/.cvsignore, gp32/console/conio.c, gp32/console/console.c, gp32/console/defaultfont.c, gp32/include/.cvsignore, gp32/include/bsp.h, gp32/include/conio.h, gp32/include/tm27.h, gp32/start/.cvsignore, gp32/start/start.S, gp32/startup/.cvsignore, gp32/startup/bspstart.c, gp32/startup/exit.c, gp32/startup/linkcmds, gp32/startup/memmap.c: New files.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/arm/gp32/configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/gp32/configure.ac b/c/src/lib/libbsp/arm/gp32/configure.ac
new file mode 100644
index 0000000000..0ed4aa60dc
--- /dev/null
+++ b/c/src/lib/libbsp/arm/gp32/configure.ac
@@ -0,0 +1,24 @@
+## Process this file with autoconf to produce a configure script.
+##
+## configure.ac,v 1.5 2003/03/11 09:39:07 ralf Exp
+
+AC_PREREQ(2.57)
+AC_INIT([rtems-c-src-lib-libbsp-arm-gp32],[_RTEMS_VERSION],[rtems-bugs@OARcorp.com])
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define foreign 1.9])
+RTEMS_BSP_CONFIGURE
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
+
+RTEMS_CHECK_NETWORKING
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
+