summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/gdbarmsim/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-10-08 16:04:56 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-10-10 10:17:09 -0500
commit62791499ebf0a6161e1541eb7587c57d88407f8b (patch)
treefaaa9f51fdd6d13727c237ddc44e87a9cdd60df4 /c/src/lib/libbsp/arm/gdbarmsim/Makefile.am
parentMove Mongoose-V specific devices into BSP. (diff)
downloadrtems-62791499ebf0a6161e1541eb7587c57d88407f8b.tar.bz2
Add console-polled.h and update all BSPs that should use it.
The file console-polled.h provides the prototypes for the three required methods when implementing a single port polled console driver. This paradigm is common on simulators and simple hardware. + Updated the BSPs Makefile.am to make console-polled.h available. + Regenerated the BSPs preinstall.sm. + Updated console support files to include <bsp/console-polled.h>. + Updated console support files to make printk() support method static.
Diffstat (limited to 'c/src/lib/libbsp/arm/gdbarmsim/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/gdbarmsim/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/gdbarmsim/Makefile.am b/c/src/lib/libbsp/arm/gdbarmsim/Makefile.am
index 9afe11e618..f13ad7de41 100644
--- a/c/src/lib/libbsp/arm/gdbarmsim/Makefile.am
+++ b/c/src/lib/libbsp/arm/gdbarmsim/Makefile.am
@@ -16,6 +16,7 @@ include_bsp_HEADERS += ../../shared/include/irq-info.h
nodist_include_HEADERS = include/bspopts.h
nodist_include_bsp_HEADERS = ../../shared/include/bootcard.h
+nodist_include_bsp_HEADERS += ../../shared/include/console-polled.h
DISTCLEANFILES = include/bspopts.h
noinst_PROGRAMS =