summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/csb337/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:49:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-22 21:49:15 +0000
commit34e9f2ac32fa845974a57d1ad969e3bf14093720 (patch)
tree45bda6356690b5ba9ee49b75cc389be63eeaadd4 /c/src/lib/libbsp/arm/csb337/Makefile.am
parent2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-34e9f2ac32fa845974a57d1ad969e3bf14093720.tar.bz2
2008-09-22 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, startup/bspstart.c: Use standardized bsp_cleanup() which can optionally print a message, poll for user to press key, and call bsp_reset(). Using this eliminates the various bsp_cleanup() implementations which had their own implementation and variety of string constants. * startup/bspreset.c: New file. * startup/bspclean.c: Removed.
Diffstat (limited to 'c/src/lib/libbsp/arm/csb337/Makefile.am')
-rw-r--r--c/src/lib/libbsp/arm/csb337/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/arm/csb337/Makefile.am b/c/src/lib/libbsp/arm/csb337/Makefile.am
index a835e38e9f..be74e76fae 100644
--- a/c/src/lib/libbsp/arm/csb337/Makefile.am
+++ b/c/src/lib/libbsp/arm/csb337/Makefile.am
@@ -27,7 +27,8 @@ dist_project_lib_DATA += startup/linkcmds
startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
../../shared/bsppredriverhook.c ../../shared/bspgetworkarea.c \
- ../../shared/bsppretaskinghook.c startup/bspstart.c startup/bspclean.c \
+ ../../shared/bsppretaskinghook.c startup/bspstart.c \
+ ../../shared/bspclean.c startup/bspreset.c \
startup/memmap.c ../../shared/bootcard.c ../../shared/sbrk.c \
../../shared/gnatinstallhandler.c
console_SOURCES = console/uarts.c ../../shared/console.c