summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/armulator/startup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-07-30 23:23:22 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-07-30 23:23:22 +0000
commitf511ae2388fd77a33acc1bcc9c7f4cd7b7841078 (patch)
tree5c99d7a273d8492ae5b5c1f61e4acfab24dc6d77 /c/src/lib/libbsp/arm/armulator/startup/Makefile.am
parent2002-07-30 Jay Monkman <jtm@smoothsmoothie.com> (diff)
downloadrtems-f511ae2388fd77a33acc1bcc9c7f4cd7b7841078.tar.bz2
2002-07-30 Joel Sherrill <joel@OARcorp.com>
* startup/Makefile.am: Added -DARM_RDI_MONITOR.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/arm/armulator/startup/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/arm/armulator/startup/Makefile.am b/c/src/lib/libbsp/arm/armulator/startup/Makefile.am
index 9101579f7b..fe534b594f 100644
--- a/c/src/lib/libbsp/arm/armulator/startup/Makefile.am
+++ b/c/src/lib/libbsp/arm/armulator/startup/Makefile.am
@@ -23,6 +23,14 @@ include $(top_srcdir)/../../../../../../automake/lib.am
#
# (OPTIONAL) Add local stuff here using +=
#
+# From newlib
+# Select which debug protocol is being used.
+# ARM_RDP_MONITOR selects the Demon monitor.
+# ARM_RDI_MONITOR selects the Angel monitor.
+# If neither are defined, then hard coded defaults will be used
+# to create the program's environment.
+AM_CPPFLAGS += -DARM_RDI_MONITOR
+
$(PGM): $(OBJS)
$(make-rel)