summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/arm/armulator/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 10:12:40 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 10:12:40 +0000
commitd348010c03f9b397596a2dfab3e8e0cba8d9481c (patch)
tree7482cb5df25b215c87624a773c3131dfd3c619f8 /c/src/lib/libbsp/arm/armulator/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d348010c03f9b397596a2dfab3e8e0cba8d9481c.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/arm/armulator/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/arm/armulator/Makefile.am b/c/src/lib/libbsp/arm/armulator/Makefile.am
index 1e26a4ca29..f2ebbf4283 100644
--- a/c/src/lib/libbsp/arm/armulator/Makefile.am
+++ b/c/src/lib/libbsp/arm/armulator/Makefile.am
@@ -5,12 +5,18 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = . include clock console startup timer start wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . clock console startup timer start wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs
+nodist_include_HEADERS += $(top_srcdir)/../../shared/include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+$(PROJECT_INCLUDE)/coverhd.h: $(top_srcdir)/../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am