summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/a29k/portsw/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-26 14:20:08 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-26 14:20:08 +0000
commit21677c0e664f84ac20ffec33209348c52d00aace (patch)
treec6d3531ac6aec1613d6b2f844db4f91bb6fa56ed /c/src/lib/libbsp/a29k/portsw/include/Makefile.am
parentNow binutils, gcc, and gdb build into a "base" package that is shared (diff)
downloadrtems-21677c0e664f84ac20ffec33209348c52d00aace.tar.bz2
Patch rtems-rc-20000118-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the a29k to automake. This patch contains * An initial merger of the libcpu/a29k stuff you sent yesterday. AFAIS, most code inside them seems to be empty stubs. One file even contains a function called mips_*** which might indicate that this part might contain mips code or the code the initial porter used as template for porting. Unfortunately, I don't know anything about the a29k so I can't comment on the details. * A dummy bsp_specs to libbsp/29k/portsw * An update to the automake files related to the a29k. Note: * This patch is completely untested, because I don't have a toolchain for it. * The files in libcpu/a29k include bsp.h => The libbsp vs. libcpu-issue hits again.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/a29k/portsw/include/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/a29k/portsw/include/Makefile.am b/c/src/lib/libbsp/a29k/portsw/include/Makefile.am
new file mode 100644
index 0000000000..b2e7788677
--- /dev/null
+++ b/c/src/lib/libbsp/a29k/portsw/include/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = bsp.h ../../../shared/include/coverhd.h
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/bsp.h: bsp.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE)/coverhd.h: ../../../shared/include/coverhd.h
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_INCLUDE) $(PROJECT_INCLUDE)/bsp.h \
+ $(PROJECT_INCLUDE)/coverhd.h
+
+all-local: $(TMPINSTALL_FILES)
+
+EXTRA_DIST = bsp.h
+
+include $(top_srcdir)/../../../../../../automake/local.am