summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-01 13:41:54 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-02-01 13:41:54 +0000
commit847dbbe6c70c6695803252b9f5132d777f9df3e7 (patch)
treee416d082e139ce4bc47ba202e21c1c51c483c233 /c/src/lib/libbsp/Makefile.am
parentRemoved references to non-existent include files. (diff)
downloadrtems-847dbbe6c70c6695803252b9f5132d777f9df3e7.tar.bz2
Patches rtems-rc-20000118-5.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that contains: * The fix for the gen68360/network/Makefile.am * automatically set permissions to 755 to scripts/buildall and scripts-ada/buildall (I remembered a trick to achieve this :). * automake support for libbsp/* and libcpu/* (Attn: This part will finally break old-style configuration for all non-public cpus) NOTES: * This patch has only been tested for a random selection of BSPs (I haven't rebuilt all toolchains yet). * This patch is against rtem-cvs as of this morning (MET). To apply: patch -p1 <rtems-rc-20000118-5.diff cvs rm -f ./c/src/lib/libbsp/Makefile.in cvs rm -f ./c/src/lib/libbsp/shmdr/Makefile.in cvs rm -f ./c/src/lib/libcpu/Makefile.in cvs add ./c/src/lib/libbsp/Makefile.am cvs add ./c/src/lib/libbsp/shmdr/Makefile.am cvs add ./c/src/lib/libcpu/Makefile.am ./bootstrap
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/Makefile.am b/c/src/lib/libbsp/Makefile.am
new file mode 100644
index 0000000000..4bc5cdb4e2
--- /dev/null
+++ b/c/src/lib/libbsp/Makefile.am
@@ -0,0 +1,19 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+# If we are building a "real" BSP, then we need to descend into the
+# appropriate CPU specific directory. The bare BSP is a special
+# case which can be built for any CPU and it resides at the same
+# level as the CPUs. If we are building the bare BSP, then descend
+# into that directory.
+
+SUBDIRS += shmdr @RTEMS_LIBBSP_CPU_SUBDIR@
+
+EXTRA_DIST = MERGE.PROCEDURE bsp.am
+
+include $(top_srcdir)/../../../../automake/subdirs.am
+include $(top_srcdir)/../../../../automake/local.am