summaryrefslogtreecommitdiffstats
path: root/c/src/lib/include/rpc/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-09-07 13:45:03 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-09-07 13:45:03 +0000
commite1d8abbe2800defb344dcce54c401733edd1d37a (patch)
tree56e416222d2ed47222be37f868a06c93656edc72 /c/src/lib/include/rpc/Makefile.am
parentRemoved by patch rtems-rc-19990820-6.diff.gz from (diff)
downloadrtems-e1d8abbe2800defb344dcce54c401733edd1d37a.tar.bz2
Applied patch rtems-rc-19990820-6.diff.gz from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> which converted many Makefile.in's to Makefile.am's. This added a lot of files.
Diffstat (limited to '')
-rw-r--r--c/src/lib/include/rpc/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/lib/include/rpc/Makefile.am b/c/src/lib/include/rpc/Makefile.am
new file mode 100644
index 0000000000..2b89842fd7
--- /dev/null
+++ b/c/src/lib/include/rpc/Makefile.am
@@ -0,0 +1,26 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+if HAS_NETWORKING
+H_PIECES = auth.h rpc.h svc.h types.h clnt.h rpc_msg.h svc_auth.h xdr.h
+
+noinst_HEADERS = $(H_PIECES)
+
+TMPINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rpc \
+$(noinst_HEADERS:%=$(PROJECT_INCLUDE)/rpc/%)
+
+$(PROJECT_INCLUDE)/rpc:
+ @$(mkinstalldirs) $@
+$(PROJECT_INCLUDE)/rpc/%.h: %.h
+ $(INSTALL_DATA) $< $@
+endif
+
+all-am: $(TMPINSTALL_FILES)
+debug-am: $(TMPINSTALL_FILES)
+profile-am: $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../automake/local.am