summaryrefslogtreecommitdiffstats
path: root/c/src/lib/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
commit1896a650fc382d343844b56f4b79efe31562755e (patch)
tree922de4dd1237cfcf6c7be0a8050e1e964fceadad /c/src/lib/configure.in
parentFixed typos. (diff)
downloadrtems-1896a650fc382d343844b56f4b79efe31562755e.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
The main topic is replacing the hard-coded values for HAS_MP and HAS_RDBG in custom/*.cfg with per-bsp configuration-time autoconf checks (This is the patch I had mentioned before earlier this week). CHANGES * HAS_MP removed from custom/*.cfg, replaced with configuration time autoconf check * HAS_RDBG removed from custom/*.cfg, replaced with configuration-time autoconf check * NEW: c/src/make/bsp.cfg.in, takes configuration-time checked per-bsp values (i.e. HAS_MP, HAS_RDBG), gets installed as $(prefix)/<bsp>/make/bsp.cfg * NEW: default.cfg includes bsp.cfg - this change is backward compatible. * IMPORT_SRC: apply VPATH instead for ts_386ex/i386ex subdirectory Makefile.ins * HACK: a bug in acpolish mis-handles addtions to makefile variables which are enclosed in gmake conditionals: c/src/lib/libbsp/m68k/ods68302/start302/Makefile.in * Apply inline_dir, HAS_MP and HAS_RDBG for avoiding configuration of unneeded subdirectories in various configure.in files. * Several minor changes in Makefile.ins and configure.ins, wrt. to the order of including *.cfg and defining Makefile variables APPLYING THE PATCH: patch -p1 < rtems-rc-19990709-4.diff ./autogen
Diffstat (limited to 'c/src/lib/configure.in')
-rw-r--r--c/src/lib/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/c/src/lib/configure.in b/c/src/lib/configure.in
index 0a2a3f3329..a7a1beea63 100644
--- a/c/src/lib/configure.in
+++ b/c/src/lib/configure.in
@@ -56,6 +56,7 @@ makefiles="$makefiles libbsp/bare/Makefile"
fi
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
RTEMS_BSP_ALIAS(${RTEMS_BSP},bspdir)
@@ -131,10 +132,9 @@ if test "$RTEMS_HAS_NETWORKING" = "yes"; then
RTEMS_CHECK_MAKEFILE(librpc)
if test "$RTEMS_HAS_RDBG" = "yes"; then
- RTEMS_CHECK_RDBG
- RTEMS_HAS_RDBG="$rtems_cv_has_rdbg";
+ RTEMS_CHECK_RDBG(RTEMS_BSP)
- if test "$rtems_cv_has_rdbg" = "yes"; then
+ if test "$HAS_RDBG" = "yes"; then
AC_CHECK_PROG(RPCGEN,rpcgen,rpcgen)
AC_PROG_AWK
if test -z "$RPCGEN"; then
@@ -144,7 +144,7 @@ if test "$RTEMS_HAS_NETWORKING" = "yes"; then
AC_MSG_ERROR([missing awk, required to build librdbg])
fi
fi
- if test "$rtems_cv_has_rdbg" = "yes"; then
+ if test "$HAS_RDBG" = "yes"; then
RTEMS_CHECK_MAKEFILE(librdbg)
fi
fi