summaryrefslogtreecommitdiffstats
path: root/c/src/exec/wrapup/rtems/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-12-19 14:37:05 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-12-19 14:37:05 +0000
commit989b9383f8119a0ebd442c35eb2e2df52b3409db (patch)
tree57562b9d97374c88c3ef36447dabba3073adc495 /c/src/exec/wrapup/rtems/Makefile.am
parent2001-12-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-989b9383f8119a0ebd442c35eb2e2df52b3409db.tar.bz2
2001-12-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* wrapup/posix/Makefile.am: Add multilib support. * wrapup/itron/Makefile.am: Add multilib support. * wrapup/rtems/Makefile.am: Add multilib support. * Makefile.am: Add multilib support.
Diffstat (limited to '')
-rw-r--r--c/src/exec/wrapup/rtems/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/c/src/exec/wrapup/rtems/Makefile.am b/c/src/exec/wrapup/rtems/Makefile.am
index f26028a16d..3b1df23777 100644
--- a/c/src/exec/wrapup/rtems/Makefile.am
+++ b/c/src/exec/wrapup/rtems/Makefile.am
@@ -7,7 +7,7 @@ AUTOMAKE_OPTIONS = foreign 1.4
LIBNAME = librtems
LIB = $(ARCH)/$(LIBNAME).a
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../automake/multilib.am
include $(top_srcdir)/../../../automake/compile.am
include $(top_srcdir)/../../../automake/lib.am
@@ -22,13 +22,10 @@ SIZE_RTEMS = $(SHELL) $(PROJECT_TOPdir)/tools/cpu/generic/size_rtems
$(LIB): ${OBJS}
$(make-library)
-# cd $(PROJECT_ROOT) ; \
-# $(SIZE_RTEMS) @RTEMS_BSP@ $(ARCH) \
-# >$(PROJECT_RELEASE)/lib/sizeinfo$(LIB_VARIANT).txt
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT).a
-$(PROJECT_RELEASE)/lib/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
+$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/$(LIBNAME)$(LIB_VARIANT).a: $(LIB)
$(INSTALL_DATA) $< $@
all-local: ${ARCH} $(TMPINSTALL_FILES)