summaryrefslogtreecommitdiffstats
path: root/c/src/exec/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-06-25 17:15:00 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-06-25 17:15:00 +0000
commite73e5766a8c9685a22812d74aa9f394ea7cae66c (patch)
tree6d04145e4ccb45389276cf1a20050c6bc6864555 /c/src/exec/wrapup/Makefile.am
parent2002-06-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-e73e5766a8c9685a22812d74aa9f394ea7cae66c.tar.bz2
2002-06-25 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add librpc. AC_PROG_RANLIB. * wrapup/Makefile.am: Add librpc. Use relative path to lib*.a for POSIX_OBJS, ITRON_OBJS, NETWORKING_OBJS.
Diffstat (limited to 'c/src/exec/wrapup/Makefile.am')
-rw-r--r--c/src/exec/wrapup/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/src/exec/wrapup/Makefile.am b/c/src/exec/wrapup/Makefile.am
index c78048844c..814c8d7ea2 100644
--- a/c/src/exec/wrapup/Makefile.am
+++ b/c/src/exec/wrapup/Makefile.am
@@ -16,11 +16,11 @@ SAPI_OBJS = $(wildcard ../sapi/src/$(ARCH)/*.o)
RTEMS_OBJS = $(wildcard ../rtems/src/$(ARCH)/*.o)
if HAS_POSIX
-POSIX_OBJS = $(wildcard ../posix/src/$(ARCH)/*.o)
+POSIX_OBJS = ../posix/src/$(ARCH)/libposix.a
endif
if HAS_ITRON
-ITRON_OBJS = $(wildcard ../itron/src/$(ARCH)/*.o)
+ITRON_OBJS = ../itron/src/$(ARCH)/libitron.a
endif
LIBCSUPPORT_OBJS = ../libcsupport/$(ARCH)/libcsupport.a
@@ -33,7 +33,9 @@ LIBIMFS_OBJS = ../libfs/src/imfs/$(ARCH)/libimfs.a
if HAS_NETWORKING
NETWORKING_OBJS = \
- ../libnetworking/wrapup/$(ARCH)/libnetworking.a
+ ../libnetworking/wrapup/$(ARCH)/libnetworking.a \
+ ../librpc/src/rpc/$(ARCH)/librpc.a \
+ ../librpc/src/rpc/$(ARCH)/libxdr.a
endif
OBJS = $(CPU_OBJS) $(CORE_OBJS) $(RTEMS_OBJS) $(SAPI_OBJS) \