summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/macros/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:30:52 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:30:52 +0000
commitff61414ac86ec7097a1c39a6904dacddf6f90599 (patch)
treef25ec3c1da4003d604a0b1a5fe90b87dc4cd7f1a /c/src/exec/score/macros/Makefile.am
parent2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ff61414ac86ec7097a1c39a6904dacddf6f90599.tar.bz2
2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/rtems/Makefile.am: Remove. * include/rtems/Makefile.am: Remove. * include/Makefile.am: Handle subdirs, require automake-1.5. * macros/rtems/Makefile.am: Remove. * macros/rtems/score/Makefile.am: Remove. * macros/Makefile.am: Handle subdirs, require automake-1.5. * inline/rtems/Makefile.am: Remove. * inline/rtems/score/Makefile.am: Remove. * inline/Makefile.am: Handle subdirs, require automake-1.5. * Makefile.am: require automake-1.5
Diffstat (limited to '')
-rw-r--r--c/src/exec/score/macros/Makefile.am40
1 files changed, 36 insertions, 4 deletions
diff --git a/c/src/exec/score/macros/Makefile.am b/c/src/exec/score/macros/Makefile.am
index f60df4f6b8..05c8ecc5aa 100644
--- a/c/src/exec/score/macros/Makefile.am
+++ b/c/src/exec/score/macros/Makefile.am
@@ -2,11 +2,43 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
-SUBDIRS = rtems
+$(PROJECT_INCLUDE)/%: %
+ $(INSTALL_DATA) $< $@
-EXTRA_DIST = README
+include_rtems_scoredir = $(includedir)/rtems/score
+
+$(PROJECT_INCLUDE)/rtems/score:
+ @$(mkinstalldirs) $@
+
+## We only build multiprocessing related files if HAS_MP was defined
+MP_I_FILES = rtems/score/mppkt.inl rtems/score/objectmp.inl rtems/score/threadmp.inl
+
+STD_I_FILES = rtems/score/address.inl rtems/score/chain.inl \
+ rtems/score/coremsg.inl rtems/score/coremutex.inl rtems/score/coresem.inl \
+ rtems/score/heap.inl rtems/score/isr.inl rtems/score/object.inl \
+ rtems/score/priority.inl rtems/score/stack.inl rtems/score/states.inl \
+ rtems/score/sysstate.inl rtems/score/thread.inl rtems/score/tod.inl \
+ rtems/score/tqdata.inl rtems/score/userext.inl rtems/score/watchdog.inl \
+ rtems/score/wkspace.inl
+
+if HAS_MP
+I_FILES = $(STD_I_FILES) $(MP_I_FILES)
+else
+I_FILES = $(STD_I_FILES)
+endif
+
+if MACROS
+include_rtems_score_HEADERS = $(I_FILES)
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+endif
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = $(STD_I_FILES) $(MP_I_FILES) README
-include $(top_srcdir)/../../../automake/subdirs.am
include $(top_srcdir)/../../../automake/local.am