summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/inline/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:30:52 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-16 13:30:52 +0000
commitff61414ac86ec7097a1c39a6904dacddf6f90599 (patch)
treef25ec3c1da4003d604a0b1a5fe90b87dc4cd7f1a /c/src/exec/score/inline/rtems/score/Makefile.am
parent2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-ff61414ac86ec7097a1c39a6904dacddf6f90599.tar.bz2
2001-10-16 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/rtems/Makefile.am: Remove. * include/rtems/Makefile.am: Remove. * include/Makefile.am: Handle subdirs, require automake-1.5. * macros/rtems/Makefile.am: Remove. * macros/rtems/score/Makefile.am: Remove. * macros/Makefile.am: Handle subdirs, require automake-1.5. * inline/rtems/Makefile.am: Remove. * inline/rtems/score/Makefile.am: Remove. * inline/Makefile.am: Handle subdirs, require automake-1.5. * Makefile.am: require automake-1.5
Diffstat (limited to 'c/src/exec/score/inline/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/inline/rtems/score/Makefile.am39
1 files changed, 0 insertions, 39 deletions
diff --git a/c/src/exec/score/inline/rtems/score/Makefile.am b/c/src/exec/score/inline/rtems/score/Makefile.am
deleted file mode 100644
index 785116b55e..0000000000
--- a/c/src/exec/score/inline/rtems/score/Makefile.am
+++ /dev/null
@@ -1,39 +0,0 @@
-##
-## $Id$
-##
-
-AUTOMAKE_OPTIONS = foreign 1.4
-
-include_rtems_scoredir = $(includedir)/rtems/score
-
-## We only build multiprocessing related files if HAS_MP was defined
-MP_I_FILES = mppkt.inl objectmp.inl threadmp.inl
-
-STD_I_FILES = address.inl chain.inl coremsg.inl coremutex.inl coresem.inl \
- heap.inl isr.inl object.inl priority.inl stack.inl states.inl \
- sysstate.inl thread.inl tod.inl tqdata.inl userext.inl watchdog.inl \
- wkspace.inl
-
-if HAS_MP
-I_FILES = $(STD_I_FILES) $(MP_I_FILES)
-else
-I_FILES = $(STD_I_FILES)
-endif
-
-include_rtems_score_HEADERS = $(I_FILES)
-
-if INLINE
-PREINSTALL_FILES = $(PROJECT_INCLUDE)/rtems/score \
- $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/rtems/score/%)
-
-$(PROJECT_INCLUDE)/rtems/score:
- @$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/rtems/score/%.inl: %.inl
- $(INSTALL_DATA) $< $@
-endif
-
-all-local: $(PREINSTALL_FILES)
-
-EXTRA_DIST = $(STD_I_FILES) $(MP_I_FILES)
-
-include $(top_srcdir)/../../../automake/local.am