summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/include/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:33:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:33:09 +0000
commit792eb742961f9195051e0eadf7fa171ca01cfc37 (patch)
tree0bf7985df6f1ca61322591057004ffed2e9865cf /c/src/exec/score/include/rtems/score/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-792eb742961f9195051e0eadf7fa171ca01cfc37.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/rtems/Makefile.am, include/rtems/score/Makefile.am, inline/rtems/score/Makefile.am, macros/rtems/score/Makefile.am Apply include_*HEADERS instead of H_FILES.
Diffstat (limited to '')
-rw-r--r--c/src/exec/score/include/rtems/score/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/c/src/exec/score/include/rtems/score/Makefile.am b/c/src/exec/score/include/rtems/score/Makefile.am
index 06445c193a..d52738d508 100644
--- a/c/src/exec/score/include/rtems/score/Makefile.am
+++ b/c/src/exec/score/include/rtems/score/Makefile.am
@@ -4,6 +4,8 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_rtems_scoredir = $(includedir)/rtems/score
+
# We only build multiprocessing related files if HAS_MP was defined
MP_H_FILES = mpci.h mppkt.h objectmp.h threadmp.h
@@ -14,13 +16,13 @@ STD_H_FILES = address.h apiext.h bitfield.h chain.h context.h copyrt.h \
userext.h watchdog.h wkspace.h
if HAS_MP
-H_FILES = $(STD_H_FILES) $(MP_H_FILES) cpuopts.h
+include_rtems_score_HEADERS = $(STD_H_FILES) $(MP_H_FILES) cpuopts.h
else
-H_FILES = $(STD_H_FILES) cpuopts.h
+include_rtems_score_HEADERS = $(STD_H_FILES) cpuopts.h
endif
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(H_FILES:%=$(PROJECT_INCLUDE)/rtems/score/%)
+ $(include_rtems_score_HEADERS:%=$(PROJECT_INCLUDE)/rtems/score/%)
$(PROJECT_INCLUDE)/rtems/score:
@$(mkinstalldirs) $@
@@ -44,6 +46,4 @@ cpuopts.h: cpuopts-tmp.h
all-local: $(PREINSTALL_FILES)
-EXTRA_DIST = $(STD_H_FILES) $(MP_H_FILES)
-
include $(top_srcdir)/../../../automake/local.am