summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/unix/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-24 14:13:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-24 14:13:15 +0000
commit1feedea303bb827de155296bd6ce1f96990537bf (patch)
tree269f476be67b406b5482aa45436090704d906899 /c/src/exec/score/cpu/unix/configure.ac
parent2001-01-22 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-1feedea303bb827de155296bd6ce1f96990537bf.tar.bz2
2002-01-23 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge in rtems/Makefile.am and rtems/score/Makefile.am. Remove gensize. Require automake-1.5. * rtems/Makefile.am: Removed. * rtems/score/Makefile.am: Removed. * rtems/score/.cvsignore: Add unixsize.h*. Add stamp-h*. * configure.ac: Add AM_CONFIG_HEADER(rtems/score/unixsize.h). * rtems/score/cpu.h: Replace CPU_CONTEXT_SIZE_IN_BYTES with SIZEOF_CPU_CONTEXT.
Diffstat (limited to 'c/src/exec/score/cpu/unix/configure.ac')
-rw-r--r--c/src/exec/score/cpu/unix/configure.ac33
1 files changed, 27 insertions, 6 deletions
diff --git a/c/src/exec/score/cpu/unix/configure.ac b/c/src/exec/score/cpu/unix/configure.ac
index 71c257a4a2..c731989fb4 100644
--- a/c/src/exec/score/cpu/unix/configure.ac
+++ b/c/src/exec/score/cpu/unix/configure.ac
@@ -27,12 +27,33 @@ RTEMS_CHECK_NEWLIB
RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
# The only use of System V IPC is the UNIX port when multiprocessing.
-if test "$HAS_MP" = "yes"; then
- RTEMS_CHECK_SYSV_UNIX
-fi
+AS_IF([test "$HAS_MP" = "yes"],
+ [RTEMS_CHECK_SYSV_UNIX])
+
+## The code fragment below had been used in tools/cpu/unix/gensize.c.
+## FIXME:
+## * The sun-stuff needs to be looked after.
+## * The pad very likely is not necessary.
+AC_CHECK_SIZEOF([CPU_CONTEXT],[],[
+#if defined(__sun__) && defined(__sparc__) && \
+ defined(__unix__) && defined(__svr4__)
+#undef _POSIX_C_SOURCE
+#define _POSIX_C_SOURCE 3
+#undef __STRICT_ANSI__
+#endif
+
+#include <stdio.h>
+#include <setjmp.h>
+
+typedef struct {
+ jmp_buf regs;
+ int isr_level;
+ int pad[4]; /* just in case */
+} CPU_CONTEXT;
+])
+
+AM_CONFIG_HEADER(rtems/score/unixsize.h)
# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-rtems/Makefile
-rtems/score/Makefile])
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT