summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/sparc/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-01 14:22:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-01 14:22:12 +0000
commitccf8925b45d1ff1f9bb23eba2d4606837ca6202c (patch)
tree29a3e6681c22bbc0658893af7d55ac1e34775535 /c/src/exec/score/cpu/sparc/configure.in
parentPatch rtems-rc-19991123-rc-1.diff from Ralf Corsepius (diff)
downloadrtems-ccf8925b45d1ff1f9bb23eba2d4606837ca6202c.tar.bz2
Patch rtems-rc-19991123-rc-1.diff from Ralf Corsepius
<corsepiu@faw.uni-ulm.de> which implements automake support for some score/cpu/<RTEMS_CPU> subdirectories and fixes a few minor configuration bugs. To apply: rm -rf c/src/exec/score/cpu/i960/wrap rm -rf c/src/exec/score/cpu/m68k/wrap rm -rf c/src/exec/score/cpu/sh/wrap rm -rf c/src/exec/score/cpu/sparc/wrap rm -rf c/src/exec/score/cpu/unix/wrap patch -p1 < rtems-rc-19991123-rc-1.diff ./bootstrap Known bugs: * "make debug|profile" in c/src/src/score/cpu/<RTEMS_CPU/Makefile does not handle recursion to subdirectories correctly (recurses too often). However, this issue is hardly visible and should be tolerable for the moment.
Diffstat (limited to '')
-rw-r--r--c/src/exec/score/cpu/sparc/configure.in40
1 files changed, 40 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/sparc/configure.in b/c/src/exec/score/cpu/sparc/configure.in
new file mode 100644
index 0000000000..ac8fd7f289
--- /dev/null
+++ b/c/src/exec/score/cpu/sparc/configure.in
@@ -0,0 +1,40 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(cpu_asm.S)
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-exec-score-cpu-sparc,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+dnl check target cc
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_NEWLIB
+
+# Check if there is custom/*.cfg for this BSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+
+PROJECT_INCLUDE="\$(PROJECT_ROOT)/$RTEMS_BSP/lib/include"
+AC_SUBST(PROJECT_INCLUDE)
+
+# Try to explicitly list a Makefile here
+AC_OUTPUT(
+Makefile
+rtems/Makefile
+rtems/score/Makefile)