summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/sh/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-01 14:22:12 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-01 14:22:12 +0000
commitccf8925b45d1ff1f9bb23eba2d4606837ca6202c (patch)
tree29a3e6681c22bbc0658893af7d55ac1e34775535 /c/src/exec/score/cpu/sh/rtems/score/Makefile.am
parentPatch rtems-rc-19991123-rc-1.diff from Ralf Corsepius (diff)
downloadrtems-ccf8925b45d1ff1f9bb23eba2d4606837ca6202c.tar.bz2
Patch rtems-rc-19991123-rc-1.diff from Ralf Corsepius
<corsepiu@faw.uni-ulm.de> which implements automake support for some score/cpu/<RTEMS_CPU> subdirectories and fixes a few minor configuration bugs. To apply: rm -rf c/src/exec/score/cpu/i960/wrap rm -rf c/src/exec/score/cpu/m68k/wrap rm -rf c/src/exec/score/cpu/sh/wrap rm -rf c/src/exec/score/cpu/sparc/wrap rm -rf c/src/exec/score/cpu/unix/wrap patch -p1 < rtems-rc-19991123-rc-1.diff ./bootstrap Known bugs: * "make debug|profile" in c/src/src/score/cpu/<RTEMS_CPU/Makefile does not handle recursion to subdirectories correctly (recurses too often). However, this issue is hardly visible and should be tolerable for the moment.
Diffstat (limited to 'c/src/exec/score/cpu/sh/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/sh/rtems/score/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/sh/rtems/score/Makefile.am b/c/src/exec/score/cpu/sh/rtems/score/Makefile.am
new file mode 100644
index 0000000000..cd110b7fc8
--- /dev/null
+++ b/c/src/exec/score/cpu/sh/rtems/score/Makefile.am
@@ -0,0 +1,34 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = cpu.h shtypes.h sh.h sh_io.h isp$(RTEMS_CPU_MODEL).h \
+ io$(RTEMS_CPU_MODEL).h
+noinst_HEADERS = \
+ cpu.h shtypes.h sh.h sh_io.h \
+ iosh7032.h ispsh7032.h \
+ iosh7045.h ispsh7045.h
+
+## HACK: this should not be here
+## Currently needed to get RTEMS_CPU_MODEL
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES = \
+$(PROJECT_INCLUDE)/rtems/score \
+$(H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am