summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/sh/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-31 15:27:02 +0000
commit4e36a2f133c68aaf637e166385eff1a05b59f38e (patch)
tree47520e4fbb8b685c25ae2909cf2a12287be4268b /c/src/exec/score/cpu/sh/Makefile.am
parentPatch rtems-rc-20000118-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4e36a2f133c68aaf637e166385eff1a05b59f38e.tar.bz2
Patches rtems-rc-20000118-3.diff and rtems-rc-20000118-4.diff from
Ralf Corsepius <corsepiu@faw.uni-ulm.de> that contain: * Modifications, (minor) corrections, cleanups to most existing Makefile.ams * Adds automake support to all remaining BSPs which have not yet been converted to automake. * Makefile.am for all remaining wrapup/Makefile.ams
Diffstat (limited to 'c/src/exec/score/cpu/sh/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/sh/Makefile.am30
1 files changed, 12 insertions, 18 deletions
diff --git a/c/src/exec/score/cpu/sh/Makefile.am b/c/src/exec/score/cpu/sh/Makefile.am
index e03b4aaff3..680b7151dc 100644
--- a/c/src/exec/score/cpu/sh/Makefile.am
+++ b/c/src/exec/score/cpu/sh/Makefile.am
@@ -11,11 +11,6 @@ include $(top_srcdir)/../../../../../../automake/lib.am
SUBDIRS = rtems
H_FILES = asm.h
-noinst_HEADERS = $(H_FILES)
-
-PREINSTALL_FILES = \
-$(PROJECT_INCLUDE) \
-$(H_FILES:%=$(PROJECT_INCLUDE)/%)
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -23,29 +18,28 @@ $(PROJECT_INCLUDE):
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-TMPINSTALL_FILES += \
-$(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o
-
$(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
$(INSTALL_DATA) $< $@
-# C source names, if any, go here -- minus the .c
C_FILES = cpu.c cpu_asm.c isp$(RTEMS_CPU_MODEL).c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
REL = $(ARCH)/rtems-cpu.rel
-$(REL): $(C_O_FILES)
+rtems_cpu_rel_OBJECTS = $(C_O_FILES)
+
+$(REL): $(rtems_cpu_rel_OBJECTS)
$(make-rel)
-all: $(ARCH) $(ARCH)/rtems.o $(REL) $(TMPINSTALL_FILES)
+PREINSTALL_FILES += $(PROJECT_INCLUDE) $(H_FILES:%=$(PROJECT_INCLUDE)/%)
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/rtems$(LIB_VARIANT).o
+
+all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(REL)
-EXTRA_DIST = \
-cpu.c \
-cpu_asm.c \
-ispsh7032.c \
-ispsh7045.c \
-rtems.c
+EXTRA_DIST = asm.h cpu.c cpu_asm.c ispsh7032.c ispsh7045.c rtems.c
include $(top_srcdir)/../../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../../automake/local.am