summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/powerpc/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-03 13:31:56 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-12-03 13:31:56 +0000
commitfc81cc9933bdccce92672a9871d4475716ca6714 (patch)
treeb5ca035d564de62dcc684512a95623e4deeb878a /c/src/exec/score/cpu/powerpc/configure.in
parentPatch rtems-rc-19991123-rc-3.diff from Ralf Corsepius (diff)
downloadrtems-fc81cc9933bdccce92672a9871d4475716ca6714.tar.bz2
Patch rtems-rc-19991123-rc-3.diff from Ralf Corsepius
<corsepiu@faw.uni-ulm.de>: The patch below provides * automake support for score/cpu/powerpc * The hack to propagate values from *.cfg to automake configuration * A fix for librdbg/powerpc/mcp750/Makefile.am (Was completely corrupted before) * Fixes some files which apparently where missing in rtems-rc-19991123-rc-2.diff * some minor configuration related patches To apply: rm -rf ./c/src/exec/score/cpu/powerpc/wrap patch -p1 < rtems-rc-19991123-rc-3.diff Attention: c/src/exec/score/cpu/[configure.in|aclocal.m4|configure] should be removed after applying the patch. Modifications had been made to the score/cpu/powerpc directory after the snapshot this was based on. In particular, the mpc750 and other_cpu directories had been renamed to new_exception_processing and old_exception_processing. After this patch was applied, modifications were made to account for this.
Diffstat (limited to 'c/src/exec/score/cpu/powerpc/configure.in')
-rw-r--r--c/src/exec/score/cpu/powerpc/configure.in44
1 files changed, 44 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/powerpc/configure.in b/c/src/exec/score/cpu/powerpc/configure.in
new file mode 100644
index 0000000000..5acd36eab3
--- /dev/null
+++ b/c/src/exec/score/cpu/powerpc/configure.in
@@ -0,0 +1,44 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(new_exception_processing)
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-exec-score-cpu-powerpc,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+dnl check target cc
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_NEWLIB
+
+# Check if there is custom/*.cfg for this BSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+
+PROJECT_INCLUDE="\$(PROJECT_ROOT)/$RTEMS_BSP/lib/include"
+AC_SUBST(PROJECT_INCLUDE)
+
+AM_CONDITIONAL(PPC_NEW_EXCEPTION_PROCESSING,test "$RTEMS_CPU_MODEL" = "mpc750" -o "$RTEMS_CPU_MODEL" = "mpc604")
+
+# Try to explicitly list a Makefile here
+AC_OUTPUT(
+Makefile
+shared/Makefile
+new_exception_processing/Makefile
+old_exception_processing/Makefile)