summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/or16/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-08-11 21:52:06 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-08-11 21:52:06 +0000
commitee5110762eaf110b05a18ab33c7ae6e617a35ed9 (patch)
tree77c472fbeb224bcedb39f20cf5369ff1f5ad3293 /c/src/exec/score/cpu/or16/rtems/score/Makefile.am
parent2000-08-11 Chris Johns <ccj@acm.org> (diff)
downloadrtems-ee5110762eaf110b05a18ab33c7ae6e617a35ed9.tar.bz2
2000-08-11 Joel Sherrill <joel@OARcorp.com>
* Shell added for or16 port based on no_cpu port with names replaced.
Diffstat (limited to 'c/src/exec/score/cpu/or16/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/or16/rtems/score/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/c/src/exec/score/cpu/or16/rtems/score/Makefile.am b/c/src/exec/score/cpu/or16/rtems/score/Makefile.am
new file mode 100644
index 0000000000..0f88d78e7a
--- /dev/null
+++ b/c/src/exec/score/cpu/or16/rtems/score/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+H_FILES = cpu.h or16.h cpu_asm.h or16types.h
+noinst_HEADERS = $(H_FILES)
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
+all-local: $(PREINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am