summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/mips/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-24 21:48:33 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-24 21:48:33 +0000
commitfda47cd1b90921c52ec995ec946560c51307c553 (patch)
tree2fbe1e7496e494b835a9e0a00cccdc81550f18d9 /c/src/exec/score/cpu/mips/configure.in
parent2000-10-23 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-fda47cd1b90921c52ec995ec946560c51307c553.tar.bz2
2000-10-24 Alan Cudmore <alanc@linuxstart.com> and
Joel Sherrill <joel@OARcorp.com> * This is a major reworking of the mips64orion port to use gcc predefines as much as possible and a big push to multilib the mips port. The mips64orion port was copied/renamed to mips to be more like other GNU tools. Alan did most of the technical work of determining how to map old macro names used by the mips64orion port to standard compiler macro definitions. Joel did the merge with CVS magic to keep individual file history and did the BSP modifications. Details follow: * Makefile.am: idtmon.h in mips64orion port not present. * asm.h: MIPS64ORION replaced with MIPS. Frame setup macros added. * cpu.c: Comments added. * cpu_asm.S: Conditionals changed. MIPS ISA level 1 support added. First attempt at exception/interrupt processing for ISA level 1 and minus any use of IDT/MON added. * idtcpu.h: Conditionals changed to use gcc predefines. * iregdef.h: Ditto. * cpu_asm.h: No real change. Merger required commit. * rtems/Makefile.am: Ditto. * rtems/score/Makefile.am: Ditto. * rtems/score/cpu.h: Change MIPS64ORION to MIPS. * rtems/score/mips64orion.h: Change MIPS64ORION to MIPS. Convert from using RTEMS_CPU_MODEL to gcc predefines to figre things out.
Diffstat (limited to '')
-rw-r--r--c/src/exec/score/cpu/mips/configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/c/src/exec/score/cpu/mips/configure.in b/c/src/exec/score/cpu/mips/configure.in
index 5c3d7b182a..d5ef3ed5ad 100644
--- a/c/src/exec/score/cpu/mips/configure.in
+++ b/c/src/exec/score/cpu/mips/configure.in
@@ -9,10 +9,10 @@ AC_CONFIG_AUX_DIR(../../../../../..)
RTEMS_CANONICAL_TARGET_CPU
-AM_INIT_AUTOMAKE(rtems-c-src-exec-score-cpu-mips64orion,$RTEMS_VERSION,no)
+AM_INIT_AUTOMAKE(rtems-c-src-exec-score-cpu-mips,$RTEMS_VERSION,no)
AM_MAINTAINER_MODE
-RTEMS_ENV_RTEMSCPU
+RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CPU
RTEMS_CANONICAL_HOST
@@ -24,6 +24,9 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_CHECK_NEWLIB
+# Check if there is custom/*.cfg for this BSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+
# Explicitly list all Makefiles here
AC_OUTPUT(
Makefile