summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/i960/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 17:45:23 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 17:45:23 +0000
commit8b25dc6bd0704444dd20d1cdc407563b5021233a (patch)
tree08e1257171de567cbe789ee8ced1477de7f28078 /c/src/exec/score/cpu/i960/Makefile.am
parent2002-01-28 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8b25dc6bd0704444dd20d1cdc407563b5021233a.tar.bz2
2002-01-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* rtems/Makefile.am: Removed. * rtems/score/Makefile.am: Removed. * configure.ac: Reflect changes above. * Makefile.am: Reflect changes above.
Diffstat (limited to 'c/src/exec/score/cpu/i960/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/i960/Makefile.am42
1 files changed, 26 insertions, 16 deletions
diff --git a/c/src/exec/score/cpu/i960/Makefile.am b/c/src/exec/score/cpu/i960/Makefile.am
index 1ee5603e2c..ce9e6bf528 100644
--- a/c/src/exec/score/cpu/i960/Makefile.am
+++ b/c/src/exec/score/cpu/i960/Makefile.am
@@ -2,32 +2,45 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
-SUBDIRS = rtems
-
-C_FILES = cpu.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-
-include_HEADERS = asm.h
-
-S_FILES = cpu_asm.S
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
-
include $(top_srcdir)/../../../../../../automake/multilib.am
include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
+
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+include_HEADERS = asm.h
+PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = \
+ rtems/score/cpu.h \
+ rtems/score/i960.h \
+ rtems/score/i960types.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
$(INSTALL_DATA) $< $@
+C_FILES = cpu.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+S_FILES = cpu_asm.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
REL = $(ARCH)/rtems-cpu.rel
rtems_cpu_rel_OBJECTS = $(C_O_FILES) $(S_O_FILES)
@@ -35,8 +48,6 @@ rtems_cpu_rel_OBJECTS = $(C_O_FILES) $(S_O_FILES)
$(REL): $(rtems_cpu_rel_OBJECTS)
$(make-rel)
-PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o
all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) \
@@ -46,5 +57,4 @@ all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) \
EXTRA_DIST = cpu.c cpu_asm.S i960RP.h rtems.S
-include $(top_srcdir)/../../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../../automake/local.am