summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:41:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:41:35 +0000
commit329509fbdd9999e9bb3b3f5cd0a09c11cec12dad (patch)
tree297dde2d20264d126d9eba130fd1e12da419f802 /c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-329509fbdd9999e9bb3b3f5cd0a09c11cec12dad.tar.bz2
2001-02-04 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am, rtems/score/Makefile.am: Apply include_*HEADERS instead of H_FILES.
Diffstat (limited to 'c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am b/c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am
index 46e19b0397..2a6bfd60fe 100644
--- a/c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am
+++ b/c/src/exec/score/cpu/hppa1.1/rtems/score/Makefile.am
@@ -1,14 +1,16 @@
##
## $Id$
##
-
+## FIXME: Handling of offsets.h needs to be reworked.
+##
AUTOMAKE_OPTIONS = foreign 1.4
+include_rtems_scoredir = $(includedir)/rtems/score
+
GENOFFSETS = $(PROJECT_TOPdir)/tools/cpu/hppa1.1/genoffsets
GENERIC_H_FILES = offsets.h
-STATIC_H_FILES = cpu.h cpu_asm.h hppa.h hppatypes.h
-noinst_HEADERS = $(STATIC_H_FILES)
+include_rtems_score_HEADERS = cpu.h cpu_asm.h hppa.h hppatypes.h
#
# (OPTIONAL) Add local stuff here using +=
@@ -18,10 +20,10 @@ offsets.h: $(GENOFFSETS) cpu.h
$(RM) $@
$(GENOFFSETS) > $@
-CLEANFILES = offsets.h
+CLEANFILES += offsets.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
- $(STATIC_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h) \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h) \
$(GENERIC_H_FILES:%.h=$(PROJECT_INCLUDE)/rtems/score/%.h)
$(PROJECT_INCLUDE)/rtems/score: