summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/h8300/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 17:48:22 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-30 17:48:22 +0000
commit14926c2e4b5f64755e63d9fcb813501b2f5ae9ac (patch)
tree5f48846738f28173eb333e9d7fec304170b342a0 /c/src/exec/score/cpu/h8300/Makefile.am
parent2002-01-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-14926c2e4b5f64755e63d9fcb813501b2f5ae9ac.tar.bz2
2002-01-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* rtems/Makefile.am: Removed. * rtems/score/Makefile.am: Removed. * configure.ac: Reflect changes above. * Makefile.am: Reflect changes above.
Diffstat (limited to 'c/src/exec/score/cpu/h8300/Makefile.am')
-rw-r--r--c/src/exec/score/cpu/h8300/Makefile.am48
1 files changed, 29 insertions, 19 deletions
diff --git a/c/src/exec/score/cpu/h8300/Makefile.am b/c/src/exec/score/cpu/h8300/Makefile.am
index 2872868ec7..0f2140197a 100644
--- a/c/src/exec/score/cpu/h8300/Makefile.am
+++ b/c/src/exec/score/cpu/h8300/Makefile.am
@@ -2,41 +2,52 @@
## $Id$
##
-AUTOMAKE_OPTIONS = foreign 1.4
+AUTOMAKE_OPTIONS = foreign 1.5
ACLOCAL_AMFLAGS = -I ../../../../../../aclocal
-SUBDIRS = rtems
-
-C_FILES = cpu.c rtems.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
-
-include_HEADERS = asm.h
-
-S_FILES = cpu_asm.S
-S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
-
-REL = $(ARCH)/rtems-cpu.rel
-
include $(top_srcdir)/../../../../../../automake/multilib.am
include $(top_srcdir)/../../../../../../automake/compile.am
include $(top_srcdir)/../../../../../../automake/lib.am
-rtems_cpu_rel_OBJECTS = $(C_O_FILES) $(S_O_FILES)
+$(PROJECT_INCLUDE)/%.h: %.h
+ $(INSTALL_DATA) $< $@
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems:
+ $(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems/score:
+ $(mkinstalldirs) $@
+
+include_HEADERS = asm.h
+PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
+
+include_rtems_scoredir = $(includedir)/rtems/score
+include_rtems_score_HEADERS = \
+ rtems/score/cpu.h \
+ rtems/score/h8300.h \
+ rtems/score/h8300types.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score \
+ $(include_rtems_score_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
$(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o: $(ARCH)/rtems.o
$(INSTALL_DATA) $< $@
+C_FILES = cpu.c rtems.c
+C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.o)
+
+S_FILES = cpu_asm.S
+S_O_FILES = $(S_FILES:%.S=$(ARCH)/%.o)
+
+REL = $(ARCH)/rtems-cpu.rel
+
+rtems_cpu_rel_OBJECTS = $(C_O_FILES) $(S_O_FILES)
+
$(REL): $(rtems_cpu_rel_OBJECTS)
$(make-rel)
-PREINSTALL_FILES = $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
-
TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib$(MULTISUBDIR)/rtems$(LIB_VARIANT).o
all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) \
@@ -46,5 +57,4 @@ all-local: $(ARCH) $(PREINSTALL_FILES) $(rtems_cpu_rel_OBJECTS) $(REL) \
EXTRA_DIST = cpu.c cpu_asm.S rtems.c
-include $(top_srcdir)/../../../../../../automake/subdirs.am
include $(top_srcdir)/../../../../../../automake/local.am