summaryrefslogtreecommitdiffstats
path: root/c/src/exec/score/cpu/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-16 16:07:17 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-16 16:07:17 +0000
commitc09454282bf05f46d967af5ed5fa9897cccca58a (patch)
treea1c2d666fb7006a5da49cbec937ecd4002a4b354 /c/src/exec/score/cpu/configure.in
parentFixed so can be included multiple times in the executive source. (diff)
downloadrtems-c09454282bf05f46d967af5ed5fa9897cccca58a.tar.bz2
Only check for System V IPC if multiprocessing is enabled. The unix
port only uses System V IPC for shared memory and semaphores to communicate between nodes in a multiprocessor configuration. If you disable multiprocessing, then this code should be unused. Thus systems like Cygwin which are POSIX but do not support System V IPC should not work.
Diffstat (limited to 'c/src/exec/score/cpu/configure.in')
-rw-r--r--c/src/exec/score/cpu/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/c/src/exec/score/cpu/configure.in b/c/src/exec/score/cpu/configure.in
index dc468089ae..5a83394fba 100644
--- a/c/src/exec/score/cpu/configure.in
+++ b/c/src/exec/score/cpu/configure.in
@@ -38,7 +38,10 @@ RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
RTEMS_CHECK_POSIX_API(RTEMS_BSP)
RTEMS_CHECK_ITRON_API(RTEMS_BSP)
-RTEMS_CHECK_SYSV_UNIX
+# The only use of System V IPC is the UNIX port when multiprocessing.
+if test "$HAS_MP" = "yes"; then
+ RTEMS_CHECK_SYSV_UNIX
+fi
# find all the Executive Makefiles
RTEMS_CHECK_MAKEFILE($RTEMS_CPU)