summaryrefslogtreecommitdiffstats
path: root/c/src/exec/rtems/include/rtems/rtems/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:32:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-02-05 18:32:04 +0000
commitf0ab3fa51ea3bb02f82bd35af163e614dbce2113 (patch)
treee3d331faf08e2aedbf70f3a5941fe498ed7ec388 /c/src/exec/rtems/include/rtems/rtems/Makefile.am
parent2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f0ab3fa51ea3bb02f82bd35af163e614dbce2113.tar.bz2
2001-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/Makefile.am, include/rtems/rtems/Makefile.am, inline/rtems/rtems/Makefile.am, macros/rtems/rtems/Makefile.am, rtems/optman/Makefile.am: Apply include_*HEADERS instead of H_FILES.
Diffstat (limited to '')
-rw-r--r--c/src/exec/rtems/include/rtems/rtems/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/c/src/exec/rtems/include/rtems/rtems/Makefile.am b/c/src/exec/rtems/include/rtems/rtems/Makefile.am
index fe27329924..3ba9e701d9 100644
--- a/c/src/exec/rtems/include/rtems/rtems/Makefile.am
+++ b/c/src/exec/rtems/include/rtems/rtems/Makefile.am
@@ -4,6 +4,8 @@
AUTOMAKE_OPTIONS = foreign 1.4
+include_rtems_rtemsdir = $(includedir)/rtems/rtems
+
## We only build multiprocessing related files if HAS_MP was defined
MP_H_FILES = eventmp.h mp.h msgmp.h partmp.h regionmp.h semmp.h signalmp.h \
taskmp.h
@@ -13,15 +15,13 @@ STD_H_FILES = asr.h attr.h cache.h clock.h config.h dpmem.h event.h \
rtemsapi.h sem.h signal.h status.h support.h tasks.h timer.h types.h
if HAS_MP
-H_FILES = $(STD_H_FILES) $(MP_H_FILES)
+include_rtems_rtems_HEADERS = $(STD_H_FILES) $(MP_H_FILES)
else
-H_FILES = $(STD_H_FILES)
+include_rtems_rtems_HEADERS = $(STD_H_FILES) $(MP_H_FILES)
endif
-noinst_HEADERS = $(STD_H_FILES) $(MP_H_FILES)
-
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/rtems \
- $(H_FILES:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
+ $(include_rtems_rtems_HEADERS:%=$(PROJECT_INCLUDE)/rtems/rtems/%)
$(PROJECT_INCLUDE)/rtems/rtems:
@$(mkinstalldirs) $@