summaryrefslogtreecommitdiffstats
path: root/c/src/exec/posix/optman/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-23 13:29:04 +0000
commitfba12eb6ff4a91fcbac1c43dd3196114cc12756b (patch)
tree34477c9b77ceab1ee81e0ea4a9ee9a6e3a3975cf /c/src/exec/posix/optman/Makefile.am
parentAdded projects chapter to FAQ. (diff)
downloadrtems-fba12eb6ff4a91fcbac1c43dd3196114cc12756b.tar.bz2
Patch rtems-rc-19991117-11.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
to convert the libc directory to automake and "dozens of small fixes for Makefile.ins/configure.ins below c/src/lib."
Diffstat (limited to '')
-rw-r--r--c/src/exec/posix/optman/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/c/src/exec/posix/optman/Makefile.am b/c/src/exec/posix/optman/Makefile.am
new file mode 100644
index 0000000000..99da45f754
--- /dev/null
+++ b/c/src/exec/posix/optman/Makefile.am
@@ -0,0 +1,22 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+C_FILES =
+H_FILES =
+
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+SRCS = $(C_FILES)
+OBJS = $(C_O_FILES)
+
+PGMS = $(C_FILES:%.c=$(ARCH)/%.rel)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(RTEMS_ROOT)/make/leaf.cfg
+
+AM_CFLAGS += $(CFLAGS_OS_V)
+
+include $(top_srcdir)/../../../../automake/local.am